como começar?

pessoal, preciso de ajuda. Eu gravei o firmware do arduino no M8 usando minha stk-500 porem ao conectar na IDE e tentar fazer funcionar, nada acontece. Dá um erro abaixo no Box ref. ao gcc. Quais os caminhos para deixar tudo instalado redondo no PC?

Obrigado.

Silverbolt

Por partes:

está usando o Atmega8 standalone (só o chip em protoboard) ou em alguma placa? Qual modelo da placa? Serial comprada, Serial feita em casa, USB, NG, Diecimila? Se for standalone, as ligações foram feitas baseadas em que circuito?

Se for em algum modelo de placa, alimentando com DC, sem conectar ao PC, o led do pino 13 pisca rapidamente após pressionar reset?

Se for standalone, coloque um resistor de 1kohm seguido de um led do pino 13 ao terra, e coloque 0volts (GND) ao pino de reset do Atmega8 (pino1 do CI). O led deve piscar rapidamente.

Se estiver piscando, o bootloader está ok.

Que sistema operacional está usando no PC? Linux (qual?), Windows (qual?).

Que versão de IDE está usando?

Se é versão 0010, o diretório de instalação foi preservado? (\arduino-0010-win(ou linux)\arduino-0010)

Abriu o programa executando arduino.exe? Tentou executar pelo Run.bat?

Se puder copiar e colar o texto do erro, pode ajudar.

Por partes:

está usando o Atmega8 standalone (só o chip em protoboard) ou em alguma placa?

estou usando uma placa, semelhante ao stk 500 da atmel.
Nenhum modelo stilo aduino.
Digamos que o chip está standalone.

Qual modelo da placa? Serial comprada, Serial feita em casa

Serial com max232 e atmega 8

, USB, NG, Diecimila? Se for standalone, as ligações foram feitas baseadas em que circuito?

sim, baseadas no circuito, havia apenas esquecido do led monitor, porem ja estou providenciando.

Se for em algum modelo de placa, alimentando com DC, sem conectar ao PC, o led do pino 13 pisca rapidamente após pressionar reset?

Ok, estarei fazendo isso no momento…
A placa de desenvolvimento já tem 8 leds monitores, basta ligar um cabo.
Sim, o led da umas piscadas rápidas e apaga.

Se for standalone, coloque um resistor de 1kohm seguido de um led do pino 13 ao terra, e coloque 0volts (GND) ao pino de reset do Atmega8 (pino1 do CI). O led deve piscar rapidamente.

Ok, está piscando corretamente…

Se estiver piscando, o bootloader está ok.

Que sistema operacional está usando no PC? Linux (qual?), Windows (qual?).

PC, windows 98SE

Que versão de IDE está usando?
0010

Se é versão 0010, o diretório de instalação foi preservado? (\arduino-0010-win(ou linux)\arduino-0010)

isso mesmo !

Abriu o programa executando arduino.exe?

cliquei direto no exe e rodou.

Tentou executar pelo Run.bat?

esse não tentei

Se puder copiar e colar o texto do erro, pode ajudar.

usando apenas o Mega 8 gravado via serial, na IDE, qual modelo devo configurar?

Valeu

Silverbolt

ao compilar o programa BLINK da isso

http://www.symphony.com.br/erro_arduino1.jpg

Ok,

Você não consegue nem compilar (Sketch/Verify/Compile)?

aparentemente tens um problema entre o IDE e o windows. Você configurou no IDE: Tools/Board/Arduino NG or older w/ Atmega8 Tools/Serial Port/COM (porta correta?)

Se não funcionar, tente rodar pelo Run.bat.

E se não funcionar, feche o IDE;

para ver mensagens de erro completas, encontre o arquivo preferences.txt (não é o arquivo do diretório arduino-0010-win\arduino-0010\lib). O arquivo que deve ser mudado deve estar em algum outro lugar. No Windows XP fica em C:\Documents and Settings\User\Dados de aplicativos\Arduino. No Win98 eu não sei.

Ao encontrá-lo, abra com Notepad, ou outro editor, e modifique a linha: upload.verbose=false para upload.verbose=true

Abra o IDE novamente.

Copie e cole a mensagem da parte de baixo do IDE(com CTRL+C e CTRL+V) e poste aqui.

Pela mensagem, apesar de você dizer que sim, o diretório original do Arduino foi alterado.

Renomeie o diretório de:
C:\projetos<mark>arduino\arduino-0010

Para:
C:\projetos<mark>arduino-0010-win\arduino-0010

E veja se funciona.

melhorou depois que mudei aquela linha pra TRUE.
porem ele achou o chip e tals
Mas não gera o HEX, dai o avrdude não consegue abri-lo e enviar ao chip

Vc. usa msn:
quer anotar por favor o meu: silverbolt90210@hotmail.com

renomeei o diretório e ficou na mesma Continua não gerando o HEX.

Dai não consegue comunicar com a board.

A mensagem deve ter ficado maior. Dá pra postar?

A mensagem deve ter ficado maior. Dá pra postar?

http://www.symphony.com.br/erro_arduino2.jpg

Tente pelo DOS: vá até o diretório: C:\projetos\arduino-0010-win\arduino-0010\hardware\tools\avr\bin>

execute (é uma linha só): avrdude -CC:\projetos\arduino-0010-win\arduino-0010\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -pm8 -cstk500 -P\.\COM1 -b19200 -D -Uflash:w:C:\projetos\arduino-0010-win\arduino-0010\examples\Digital\Blink\applet\Blink.hex:i

A mensagem deve ter ficado maior. Dá pra postar?

onde baixo o HEX do blink led? assim eu coloco ele no diretorio e tento comunicar. Pois o que acontece ai é que a IDE não gera o HEX e não acha ele na hora de enviar

Ah, espera aí!

Você está dando reset antes de fazer o upload do programa?

Você tem que dar reset para carregar sketches no Atmega. E o momento do reset é meio complicado.

Compile e veja quantos segundos demora para terminar de compilar. Depois, dê upload, conte os mesmos segundos (menos uns 3 a 5 segundos) e aí dê reset.

Se não conseguir o timing, ou, se achar mais fácil, usando o pino 4 do cabo serial, ligue ele a um capacitor de 100nF e ao pino 1 do Atmega. É um auto reset improvisado, que ressetará logo antes do upload.

Acho que seu problema é o reset, mas para você saber, o .hex do blink vem junto com o IDE 0010. Se você tem o IDE, o blink tem que estar lá: \arduino-0010-win\arduino-0010\examples\Digital\Blink\applet\blink.hex

Tente pelo DOS: vá até o diretório: C:\projetos\arduino-0010-win\arduino-0010\hardware\tools\avr\bin>

execute (é uma linha só): avrdude -CC:\projetos\arduino-0010-win\arduino-0010\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -pm8 -cstk500 -P\.\COM1 -b19200 -D -Uflash:w:C:\projetos\arduino-0010-win\arduino-0010\examples\Digital\Blink\applet\Blink.hex:i

não dá na linha DOS tem um limite max de caracteres que consigo digitar quando chega no baud rate 19200 não vai mais.

Ah, espera aí!

Você está dando reset antes de fazer o upload do programa?

Você tem que dar reset para carregar sketches no Atmega.
E o momento do reset é meio complicado.

Compile e veja quantos segundos demora para terminar de compilar. Depois, dê upload, conte os mesmos segundos (menos uns 3 a 5 segundos) e aí dê reset.

Se não conseguir o timing, ou, se achar mais fácil, usando o pino 4 do cabo serial, ligue ele a um capacitor de 100nF e ao pino 1 do Atmega. É um auto reset improvisado, que ressetará logo antes do upload.

Acho que seu problema é o reset, mas para você saber, o .hex do blink vem junto com o IDE 0010. Se você tem o IDE, o blink tem que estar lá:
\arduino-0010-win\arduino-0010\examples\Digital\Blink\applet\blink.hex

vou fazer o reset
Mas acho que não é isso
Pois chequei na pasta digital\applet e só tem o blink.cpp e não o HEX
se eu tivesse o hex na mão ja dava pra testar.

Nunca vi isso, mas pegue os aruivos do blink aqui: http://www.4shared.com/file/35722348/2870f20d/Blink.html unzip, e coloque no diretório certo: \arduino-0010-win\arduino-0010\examples\Digital\Blink\applet\

E não esqueça do reset. Avise se der certo.

não tem como alguem me mandar o BLINK.HEX pro meu email ?

silverbolt90210@hotmail.com

Nunca vi isso, mas pegue os aruivos do blink aqui: http://www.4shared.com/file/35722348/2870f20d/Blink.html unzip, e coloque no diretório certo: \arduino-0010-win\arduino-0010\examples\Digital\Blink\applet\

E não esqueça do reset. Avise se der certo.

Cara, olha que fato curioso Eu baixei os files, descompactei na pasta correta. quando mandei fazer o upload, a IDE apagou todos os files. Dai não acreditei. Abri a IDE lado a lado com a janela com os file e as ví desaparecendo :'(

Meu problema mesmo está em gerar o HEX Quando compilo, não gera nada

http://www.symphony.com.br/erro_arduino3.jpg