Compatibility with Ethernet Switch

Hi,

I am using arduino mega 2560 with ethernet shield W5100(100Mbps). I am trying to upload my sketch over ethernet using Ariadne bootloader . I do it successfully.

I connect my arduino to 24-port Gigabit Ethernet Switches( 2000Mbps) using RJ45 ethernet cable.Now my arduino get PINGED and get response.

Problem : In between arduino(including ethernet shield) and 24-port Gigabit Ethernet Switches( 2000Mbps) I place a 8-Port 10/100Mbps Fast Ethernet Switch.

Now my connection is like

24-port Gigabit Ethernet Switches( 2000Mbps) ------> 8-Port 10/100Mbps Fast Ethernet Switch ------->

arduino mega 2560 with ethernet shield W5100.

Now arduino will not pinged and not get any response.

I am using::

24-port Gigabit Ethernet Switches( 2000Mbps) : http://www.downloads.netgear.com/files/GDC/datasheet/en/JGS516v2-JGS524v2.pdf

8-Port 10/100Mbps Fast Ethernet Switch : https://www.streakwave.com/mmSWAVE1/Video/PS2208b_DSv1.0.pdf

Can anyone please suggest a solution for this ?

Sounds like a switch problem. Are you trying to access it from a computer connected to the Streakwave switch? Or is the computer connected to the Netgear switch?

Hi, The computer is connected to Netgear switch.

How about if the computer is connected to the Streakwave switch? Does it recognize the Arduino?

Hi,

The computer get pinged when it connected to streakwave switch. But the streakwave switch not recognize the arduino.....

Are you using a static IP or using DHCP on the Arduino? If static, have you tried DHCP?

If you never sent a packet from the Arduino the switch has no way to know the port the device is attached to. Using DHCP would solve that problem.