compile err with a github library: "maybe you meant to use ->"

I am adding a Chronodot to my project. I looked up various libraries and found one that seemed simple, but when I try to run the basic test I get a compile error which I don't understand, i.e. I don't understand struct declarations well enough to know what I should do to fix it.

Chronodot RTC;

void setup () {
    Serial.begin(9600);
    Serial.println("Initializing Chronodot.");

    Wire.begin();
    RTC.begin();

I get the compile error on the RTC.begin function:

request for member 'begin' in '1074666080u', which is of pointer type 'Rtc*' (maybe you meant to use '->' ?)

So, taking a hint, I tried changing the code to read RTC->begin. But that didn't make it happy.

It then complained : struct Rtc has no member named 'begin'.

I poked around a bit in the source and found no instances of "Rtc". Where is this mixed-case name coming from I wonder.

So hmmm. This is a bit beyond me. Just try another library? Or is this a Well Known Gotcha that can be fixed with one or two edits?

(a few minutes later) wow, I get the same error message with a different library for the Chronodot. More googling required...

OK. This I think I can do. But can't I delete this post which has become irrelevant?

1 Like

Rename it :

Chronodot myRTC;
...
myRTC.begin();