compile error

Help!
I am new to this IDE but cant seem to get it to compile anything. I am running on win xp. trying to get simple sketch to compile but I get the message below. I have tried to uninstall and delete the sw a few times but keep having problems. I am using a nodemcu 1.0 and it works with the lua tools. I would much rather work in this tool. Here is the message:

Arduino: 1.6.7 (Windows XP), Board: "NodeMCU 1.0 (ESP-12E Module), 80 MHz, Serial, 115200, 4M (3M SPIFFS)"

In file included from c:\documents and settings\michael\local settings\application data\arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2\xtensa-lx106-elf\include\c++\4.8.2\bits\stl_algobase.h:59:0,

from c:\documents and settings\michael\local settings\application data\arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2\xtensa-lx106-elf\include\c++\4.8.2\memory:62,

from C:\Documents and Settings\Michael\Local Settings\Application Data\Arduino15\packages\esp8266\hardware\esp8266\2.0.0\cores\esp8266\Esp.cpp:24:

c:\documents and settings\michael\local settings\application data\arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2\xtensa-lx106-elf\include\c++\4.8.2\xtensa-lx106-elf\bits\c++config.h:426:29: fatal error: bits/os_defines.h: No such file or directory

#include <bits/os_defines.h>

^

compilation terminated.

exit status 1
Error compiling.

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.

I have followed everything to check and make sure that the files are really there, but it still won't compile. Any suggestions would be appreciated.

Michael

I would recommend trying Arduino IDE 1.6.5r5 to see if that will work for you. I don't think esp8266 has worked out all their bugs with supporting Arduino IDE 1.6.6 and 1.6.7.

pert,
Thanx that did it. Up and running.

Michael

I had a similar problem with XP and IDE 1.6.8.
After a portable Installation like http://www.instructables.com/id/Portable-installation-guide-of-Arduino-IDE-v165-fo/?ALLSTEPS it works.
In a Windows 10 environmet the standard installation works without problems.