Compile errors

Hi All,

I installed 1.8.5 on new Win10 laptop, and get the following error when compiling. I have previous IDE on WIN7 at home, and no problems there.

Look at the last highlited lines. How do I get around this?

and is the last line error a consequent of the first error?
I'm using a NodeMCU 2.0, which does not exist in board library yet. I have tried generic Esp8266 as well, no luck.

Many Thanks

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\username\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\username\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\username\Documents\Arduino\libraries -fqbn=esp8266:esp8266:nodemcuv2:CpuFrequency=80,UploadSpeed=115200,FlashSize=4M3M -ide-version=10805 -build-path C:\Users\username\AppData\Local\Temp\arduino_build_544323 -warnings=none -build-cache C:\Users\username\AppData\Local\Temp\arduino_cache_934761 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.xtensa-lx106-elf-gcc.path=C:\Users\username\AppData\Local\Arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2 -prefs=runtime.tools.mkspiffs.path=C:\Users\username\AppData\Local\Arduino15\packages\esp8266\tools\mkspiffs\0.1.2 -prefs=runtime.tools.esptool.path=C:\Users\username\AppData\Local\Arduino15\packages\esp8266\tools\esptool\0.4.9 -verbose C:\Users\username\Documents\Arduino\DS18B20\ESP8266_EmonCMS_1wire_Temp\ESP8266_EmonCMS_1wire_Temp.ino
C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\username\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\username\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\username\Documents\Arduino\libraries -fqbn=esp8266:esp8266:nodemcuv2:CpuFrequency=80,UploadSpeed=115200,FlashSize=4M3M -ide-version=10805 -build-path C:\Users\username\AppData\Local\Temp\arduino_build_544323 -warnings=none -build-cache C:\Users\username\AppData\Local\Temp\arduino_cache_934761 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.xtensa-lx106-elf-gcc.path=C:\Users\username\AppData\Local\Arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2 -prefs=runtime.tools.mkspiffs.path=C:\Users\username\AppData\Local\Arduino15\packages\esp8266\tools\mkspiffs\0.1.2 -prefs=runtime.tools.esptool.path=C:\Users\username\AppData\Local\Arduino15\packages\esp8266\tools\esptool\0.4.9 -verbose C:\Users\username\Documents\Arduino\DS18B20\ESP8266_EmonCMS_1wire_Temp\ESP8266_EmonCMS_1wire_Temp.ino
Using board 'nodemcuv2' from platform in folder: C:\Users\username\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.3.0
Using core 'esp8266' from platform in folder: C:\Users\username\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.3.0
open C:\Users\username\AppData\Local\Temp\arduino_build_544323\sketch\ESP8266_EmonCMS_1wire_Temp.ino.cpp: Access is denied.
Error compiling for board NodeMCU 1.0 (ESP-12E Module)

Please use code tags (</> button on the toolbar), not only when posting code, but also when you post error/warning messages.

It’s possible this error is caused by your antivirus software. Try TEMPORARILY disabling your antivirus for a single compilation to see if the problem goes away, then turn it back on. If you identify that as the problem then you can work on configuring your antivirus to whitelist the Arduino IDE and associated programs.

Thanks, will try.