Compiler issues

I have a computer that is having issues compiling the sketch. It compiles and uploads fine but has issues running. The sketch doesn't seem to matter. I have this issue with all sketches. My code as well as example:blink. My arduino 1.0 directory is in my dropbox folder (web sync folder). On any computer except this one the code compiles, uploads, and runs fine. Even on this machine it uploads fine but runs erratically. I can upload the same sketch on a different computer and it runs fine. I thought it may be an issue with USB drivers though all USB drivers are installed properly. I compiled the sketch and pulled the .hex file from the temp directory and loaded this directly onto a ATmega328 with my STK600. I get the same result. It seems to be only sketches compiled on this machine. The arduino 1.0 directory on this machine is always identical to that on others because of the dropbox web sync folder so i'm using the same WinAVR program files as I do on another machine. Though ive tried using different instances of the arduino 1.0 IDE installed to different locations on the computer. Ive even gone so far as reinstalling windows to no avail. The comp im having trouble with is asus motherboard intel I5 8gb ram. windows 7 x64 ultimate. (illegal copy though so are my other computers and they compile fine). Hopefully someone will have an idea as what to try next.

The next thing to try is posting the errors you get and what you expected if it would run successfully. To let us analyze what a correct behavior would be post the full code you upload too. I don’t think it’s related to your PC’s hardware.

There are no errors. It compiles and uploads fine regardless of computer. It just doesnt run correctly when compiled on this one. Also the sketch doesn't matter either. The blink sketch included with the IDE. if compiled on another machine it runs fine. If compiled on this one the LED on pin 13 acts erratic. I can post my code which drives 3x TLC5940s but its big and this issues is not specific to that code. Ill post the code and some images (compiled on this machine vs another) as soon as I can.

lbenson: It just doesnt run correctly

Feel free to elaborate.

You still didn't define what "runs erratic" means. Have you tried to run your "erratic" code without a connection to you "faulty" computer? This means connecting a separate power supply and disconnecting the USB cable. Maybe your computer does not supply enough current to the Arduino (against the USB specification).

Sorry about that. If I upload say... the BasicUse sketch included with the TLC5940 library (Knight Rider effect). Using 3 TLC and 16RGB LEDs. The first 5 LEDs are off.The second 2/3s of the LEDs (TLC channels 17-47) light up mostly white (all 3 colors on) the hue varies slightly from LED to LED. The code does seem to run underneath as i can see the knight rider effect going back and forth underneath the static mess. I have tried running this from 3.3v USB (the Sparkfun FT232RL adapter) as well as 5V/3.3 from my DC bench supply with no USB cable connected. same issue regardless, so long as im using this machine. A picture will do my cause a lot more justice.

Have you tried supplying DC from a power supply while uploading the code? If the computer does not supply enough current during upload a broken code image may be written to the flash resulting in strange behavior.

Another thing to try: enable full compiler output in the preferences of the IDE. This enable you to locate the compiled binary code which is uploaded. Do this on the "faulty" and on another computer and then compare the two codes. They should be identical.

Now that I had not considered. Will do next! I'll also post the verbose output of the two if not identical. Thanks so much for the help!

Another possibility: some background task on the "broken" computer is periodically scanning the serial ports, causing the Arduino to be reset... Cellphone support is pretty infamous for doing this sort of thing.