Compiling error (avr-g++)

I have a couple of Arduino Uno R3 (an original one and a clone) and I can not upload sketches on both boards (I tried the BLINK example).

I am working with a PC with Vista OS where I installed last version of IDE 1.6.7 (but I tried also .5 and .6 versions with same problems).

USB driver has been correctly installed (serial monitor works properly: RX LED blinks when strings are sent).

I have followed the installing procedure step by step accordingly to the official Web site and I have also tried some tricks listed on some Forum (such as instaling IDE from .zip files, using particular names to directories, etc.) but in all the cases I found out the same "error during compilation" stating that some files are missing.

I report belows the verbose message:

Arduino:1.6.7 (Windows Vista), Scheda:"Arduino/Genuino Uno"

C:\Arduino\arduino-builder -dump-prefs -logger=machine -hardware "C:\Arduino\hardware" -tools "C:\Arduino\tools-builder" -tools "C:\Arduino\hardware\tools\avr" -built-in-libraries "C:\Arduino\libraries" -libraries "C:\Users\HP\Documents\Arduino\libraries" -fqbn=arduino:avr:uno -vid-pid=0X2341_0X0043 -ide-version=10607 -build-path "C:\Users\HP\AppData\Local\Temp\build287b75373793f26e02765ea0d8afd8ef.tmp" -warnings=none -prefs=build.warn_data_percentage=75 -verbose "C:\Arduino\examples\01.Basics\Blink\Blink.ino"
C:\Arduino\arduino-builder -compile -logger=machine -hardware "C:\Arduino\hardware" -tools "C:\Arduino\tools-builder" -tools "C:\Arduino\hardware\tools\avr" -built-in-libraries "C:\Arduino\libraries" -libraries "C:\Users\HP\Documents\Arduino\libraries" -fqbn=arduino:avr:uno -vid-pid=0X2341_0X0043 -ide-version=10607 -build-path "C:\Users\HP\AppData\Local\Temp\build287b75373793f26e02765ea0d8afd8ef.tmp" -warnings=none -prefs=build.warn_data_percentage=75 -verbose "C:\Arduino\examples\01.Basics\Blink\Blink.ino"
"C:\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10607 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-IC:\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Arduino\hardware\arduino\avr\variants\standard" "C:\Users\HP\AppData\Local\Temp\build287b75373793f26e02765ea0d8afd8ef.tmp\sketch\Blink.ino.cpp" -o "nul"
"C:\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10607 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-IC:\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Arduino\hardware\arduino\avr\variants\standard" "C:\Users\HP\AppData\Local\Temp\build287b75373793f26e02765ea0d8afd8ef.tmp\sketch\Blink.ino.cpp" -o "nul"
"C:\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10607 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-IC:\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Arduino\hardware\arduino\avr\variants\standard" "C:\Users\HP\AppData\Local\Temp\build287b75373793f26e02765ea0d8afd8ef.tmp\sketch\Blink.ino.cpp" -o "C:\Users\HP\AppData\Local\Temp\build287b75373793f26e02765ea0d8afd8ef.tmp\preproc\ctags_target_for_gcc_minus_e.cpp"
avr-g++: error: CreateProcess: No such file or directory

exit status 1
Errore durante la compilazione

Any help is appreciated.
Thanks so much

Maurizio

P.S.: installed IDE version 1.5.8-windows and it runs OK ... so what went wrong with newest releases?

Absolutely the same problem with the same conditions. I finished installing all the software I needed (1 week), just after my other laptop broke down the monitor (Windows 7), then I wanted to recorded some demos , but surprise! Arduino IDE 1.6.7 can not even compile.

It would be a tedious to change Windows Vista to Windows 7 and start again. SO I really need help with this issue. Thanks In advance.