Compiling Error

Hey guy's I was hoping someone might be able to give me a hand and explain what's going on with this compiling error:

"Arduino: 1.6.6 (Mac OS X), Board: "Arduino/Genuino Uno"

avr-g++: error: missing filename after '-o' exit status 1 Error compiling.

This report would have more information with "Show verbose output during compilation" enabled in File > Preferences."

So, "21 bugs in your code, just 21 bugs to find, find one bug, patch now, 996 bugs in your code..."

Can anybody explain to me why this is going crazy?

...mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10606 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-I/Users/Tuck/Library/Arduino15/packages/arduino/hardware/avr/1.6.10/cores/arduino" "-I/Users/Tuck/Library/Arduino15/packages/arduino/hardware/avr/1.6.10/variants/standard" "-I/Users/Tuck/Documents/Arduino/libraries/TMRpcm" "-I/Users/Tuck/Desktop/Arduino.app/Contents/Java/libraries/SD/src" "-I/Users/Tuck/Library/Arduino15/packages/arduino/hardware/avr/1.6.10/libraries/SPI/src" "/var/folders/qf/hy__ltxs14n43dyw93nlx8z00000gn/T/build7601fc7e22abcc18abcd7d0235131b56.tmp/sketch/Sound_Tests.ino.cpp" -o ""
avr-g++: error: missing filename after '-o'
Using library TMRpcm at version 1.0 in folder: /Users/Tuck/Documents/Arduino/libraries/TMRpcm 
Using library SD at version 1.0.6 in folder: /Users/Tuck/Desktop/Arduino.app/Contents/Java/libraries/SD 
Using library SPI at version 1.0 in folder: /Users/Tuck/Library/Arduino15/packages/arduino/hardware/avr/1.6.10/libraries/SPI 
exit status 1
Error compiling.

I should add, this is what I'm doing: http://pastebin.com/p5Dk1Vba https://www.youtube.com/watch?v=LbqPgJe3Qd4