compiling in FastLED gives error in own header file clockless_block_arm_sam.h


I've done a lot of searching and I didn't find this issue elsewhere - apologies if I didn't look in the right place!

I'm trying to set up Arduino IDE + Due + FastLED. When I try to compile my code, I get the following error, complaining about something wrong in a FastLED header file. FastLED example files compile just fine btw, though last night they gave me the same error.

Here is the error:

In file included from /Users/diane/Documents/Arduino/libraries/FastLED-3.1.3/platforms/arm/sam/fastled_arm_sam.h:9:0,
                 from /Users/diane/Documents/Arduino/libraries/FastLED-3.1.3/platforms.h:18,
                 from /Users/diane/Documents/Arduino/libraries/FastLED-3.1.3/FastLED.h:52,
                 from /Users/diane/Documents/Arduino/libraries/FastLED-3.1.3/bitswap.h:4,
                 from /Users/diane/Documents/Arduino/diane_journey/Journey/Journey.ino:1:
/Users/diane/Documents/Arduino/libraries/FastLED-3.1.3/platforms/arm/sam/clockless_block_arm_sam.h: In static member function 'static void InlineBlockClocklessController<LANES, FIRST_PIN, T1, T2, T3, RGB_ORDER, XTRA0, FLIP, WAIT_TIME>::writeBits(uint32_t&, Lines&, Lines&, PixelController<RGB_ORDER, LANES, (((1 << LANES) - 1) & ((FIRST_PIN == 2) ? 255 : 255))>&)':
/Users/diane/Documents/Arduino/libraries/FastLED-3.1.3/platforms/arm/sam/clockless_block_arm_sam.h:144:34: error: there are no arguments to 'transpose8x1' that depend on a template parameter, so a declaration of 'transpose8x1' must be available [-fpermissive]
/Users/diane/Documents/Arduino/libraries/FastLED-3.1.3/platforms/arm/sam/clockless_block_arm_sam.h:144:34: note: (if you use '-fpermissive', G++ will accept your code, but allowing the use of an undeclared name is deprecated)
exit status 1
Error compiling for board Arduino Due (Programming Port).


After working on this for hours last night, I just deleted the correct unused header file from my program and it works now, 2 minutes after this post.

This forum is amazing! Solved my problem immediately :slight_smile:

The fastLED lib seems AVR specific even though there are variants in the lib.

I dont have a DUE but they also wont compile for the 101 board.
But even more strange is that the examples compile for the MKR1000

Arduino: 1.8.2 (Windows 7), Board: "Arduino/Genuino 101"

In file included from D:\Sketches\libraries\FastLED-3.1.3/led_sysdefs.h:27:0,

                 from D:\Sketches\libraries\FastLED-3.1.3/FastLED.h:44,

                 from D:\Sketches\libraries\FastLED-3.1.3\examples\DemoReel100\DemoReel100.ino:1:

D:\Sketches\libraries\FastLED-3.1.3/platforms/avr/led_sysdefs_avr.h:12:20: fatal error: avr/io.h: No such file or directory

 #include <avr/io.h>


compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino 101.

Seems more like the variants are not getting called correctly but that's waaay beyond me.
Maybe you have to alter the header file ?

BTW installed the DUE board package and it compiles just fine for examples here with zero issues.
Maybe post an issue in the GITHUB lib page for fast LED.

Also check out

EDIT I posted anyway just as you posted it was fixed LOL...The git pages doesn't say it supports DUE but clearly it does !