Compiling/Installing avr-libc on 64bit Debian Linux. [SOLVED] (Not compile tho.)

I'm running 64 bit LMDE. That's Linux Mint Debian Edition. It's essentially a rolling release Debian with some custom Linux Mint conveniences.

Anyways, I've been following this to install the avr compiler toolchain for the arduino software: Building and Installing the GNU Tool Chain

I have the arduino IDE in my home folder set to execute from the command ".arduino" (I did this to blender as well due to there also being a repository version) and I've installed binutils-avr and avrdude from a repository. I followed the instructions to install gcc-avr from source and was moving on to avr-libc. It's all caught up in ./configure because it can't figure out the object file suffix. Here's what it has to say:

jorh@jorh-inspiron ~/Downloads/avr-libc-1.7.2rc2252 $ ./configure --build=`./config.guess` --host=avr
checking build system type... x86_64-unknown-linux-gnu
checking host system type... avr-unknown-none
checking if configuring for cross compile... yes
checking if target host is avr... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for avr-strip... avr-strip
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for avr-gcc... avr-gcc
checking whether we are cross compiling... yes
checking for suffix of object files... configure: error: in `/home/jorh/Downloads/avr-libc-1.7.2rc2252':
configure: error: cannot compute suffix of object files: cannot compile
See `config.log' for more details

I also tried ./bootstrap before the ./configure . It makes some directories, but the output of ./configure is the same.

I cheated! I went to the Atmel website and downloaded the toolchain from there. This topic may interest you. The good stuff for you is reply #5.

You know your repository avr-libc version was (or soon will be) changed. I was just notified that Debian and Ubuntu have upgraded to avr-libc v1.7.1 with my patches. The Arduino IDE in your repository will also have my patch in it. Last post in this topic:

I’ve read that they’re somewhere in a repository, but I’m not as used to APT sources, I’m used to Arch Linux and pacman.

Because it’s distributed by Linux Mint, I’m thinking I might have non-standard debian repositories. This is what my sources.list looks like:

jorh@jorh-inspiron /etc/apt $ cat sources.list
deb http://packages.linuxmint.com/ debian main upstream import romeo
deb http://ftp.debian.org/debian testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org testing main non-free
deb http://download.tuxfamily.org/makehuman/deb/amd64/ /

I've figured out why I don't have them (avr-libc and gcc-avr) in my repos. For whatever reason, they are not in testing, but are in unstable (sid) and for whatever reason a couple of older stables.

Anyways, I'm just gonna hop over to sid a bit for the two packages and then hop back. There's also probably a way to make it just get those two packages, so I'll do a bit more research to find out.