Complying Sketch is never finishes

After a long time not using Arduino, I have installed the latest version 1.6.7 on my Windows 10 PC.

When I try to upload or even verify a sketch (even empty) the complying is never finished.

I have tried to install the program couple of times but noting changed. I even tried to install it to a different directory.

Does anyone have any suggestions?

Try an older version of the IDE, v1.6.5 or earlier.

I have also tried an older version but its the same. I waited to see if it will finish complying. It took 10 minutes to comply and upload to Arduino Mega. This was an empty sketch.

I have solved the problem. It was because of Avast antivirus program. If I waited long enough it was complying but took like 10 minutes. I made an exception for Arduino IDE on the antivirus program and it is now working fine.

!!! Avast you say? That antivirus program causes so many problems - I’d consider switching to a new AV program.

Agreed, avast is overrated now. I use Eset for av and firewall. Awesome software.