Computer doesn’t recognize LilyPad protosnap plus

Hi,
I’m new to the forum and new to Arduino. Except a few classes in Arduino programming a lot of years ago my experience is zero. So I’m not sure if this is the right place to ask my question or not :wink:
Recently I have started using electronics in sewing projects. During some searching on the internet I saw e-textile stuff and got quite enthusiastic. Since Sparkfun created a whole line for sewable electronics with Lilypad I thought it would be easy to use a Sparkfun LilyPad ProtoSnap plus. The only problem is that my computer won’t recognize it. It doesn’t make a sound, it’s not showed as a comport in my device management nor as an unknown device. I’m using the latest version of Arduino and my computer is an Asus laptop running on Windows 10. I can’t find a serial number on the LilyPad but the package says “DEV-14346” and ome chip on the LilyPad reads MEGA32U4-MJ. I have tried multiple micro usb cables and have now ordered a new one which says it can be used for programming Arduino’s. Since the other cables are all from old mobile phones and a headphone, I’m not sure if they can be used for the LilyPad. Is there someone that can help me to let my computer recognize it?
Thanks a lot :slight_smile:

  1. I'm not familiar with the device. I see it has an 'on/off' switch; maybe you overlooked that?
  2. Sparkfun has a hookup guide for most of it's boards; the Arduino part is described here: LilyPad ProtoSnap Plus Hookup Guide - learn.sparkfun.com

There are two types of microUSB cables; those with data wires and those without. The latter can be the reason for your problem; it can only be used for charging. Cables that come with cell phones have the data wires (I haven't seen ones without yet) and should work else you could e.g. not copy files from phone to PC.

Thank you for your, there is an on/off switch on it and it needs to be “On” in order to be able to communicate with the computer. And I’m sure it’s “On”. I’ve tried to use the hookup guide, but the only thing it tells with troubleshooting is trying a different cable (that doesn’t solve this problem). On the Arduino software page it tells ne how it can be an unknown device and how to tell it where to find the right driver so it gets recognized by the computer. But this doesn’t work for mel because my computer doesn’t react to me connecting the cable to my laptop. It doesn’t make the usual sound it makes whenever I connect an USB-device. But it powers the LilyPad, so I’m a bit clueless what to do next :sweat_smile:

My bet is on 'bad' cables; can you test them with a cell phone for data transfer?

It also tells you to install the Sparkfun AVR boards. Did you? It might install a missing driver, not sure.

I have installed the Sparkfun AVR drivers, and I can select de LilyPad Usb Plus under bords, but I can’t select a port. I don’t have a recent device that uses a micro usb to transfer data. So I’m not totally sue if the cable is working or not. I have tried my e-reader, but it’s around 10 years old and I’m unsure if it’s still supported by Sony… at the moment my laptop is treating it the same as the LilyPad Protosnap plus. They both get ignored completely. Normally the ereader would display a message asking me if I want the computer to recognize it or not. But it doesn’t pop up. Maybe the drivers of the ereader are outdated, maybe Sony doesn’t support it anymore, maybe it can’t work with Windows 10. And maybe it’s just the wrong type of micro usb. So I think I’ll just have to wait for the new usb cable to arrive :wink: But thank you very much for helping! :smiley:

I've got a new USB cable and now it works! So thank you very much for your help!