Computer Not Recognizing Arduino Uno

OS: 64- bit operating system, x64-based processor

I have an Arduino Uno

It was working up until a point where I tried to use a mp3 sheild as well as an ultrasonic sensor ontop of the shield through the ports on the mp3 sheild (https://www.creatroninc.com/product/mp3-shield/) . But I couldnt even upload it because the error messaged occured.

The messages displayed is; Sketch uses 450 bytes (1%) of program storage space. Maximum is 32,256 bytes. Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes. avrdude: ser_open(): can't open device "\.\COM4": The system cannot find the file specified.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

And as an attempt to fix it I went to my drivers I found that windows was not detecting my board, So i tried to update the driver under com & ports but, failed to fix the issue, so I unistalled it planing to reinstall it. Now I cannot reinstall it because it isn't detecting my arduino. The arduino still lights up when I plug it in. I am very new to arduino as it is my first time owning one, so I'd like to know if it can be fixed or if I need a new one, any help will be appericiated, thanks. :D

Update: It recognizes a device is connected (unknown device) when I connect the arduino with the mp3 sheild