Computer to Arduino Serial Interface with Stepper Motors

I’m trying to send commands via USB serial from the computer to the arduino using serial.parse(), but for some reason they stepper motors are not moving, despite receiving integers. Basically, i send a set of 3 (or 4) integers which control 2 stepper motors and a solenoid(which is only on/off). The arduino properly echo’s back the integers i send it (meaning they are stored in the memory as variables) but no movement on the motors. Any ideas how to make this work?

// MultiStepper.pde

#include <AccelStepper.h>

// Define some steppers and the pins the will use
AccelStepper stepper1(1,9,8); // Defaults to AccelStepper::FULL4WIRE (4 pins) on 2, 3, 4, 5
AccelStepper stepper2(1,5,6);

int xMove = 3;
int yMove = 5;
int solMove = 6;

void setup()
{  
    stepper1.setMaxSpeed(200.0);
    stepper1.setAcceleration(100.0);
    stepper1.moveTo(24);
    
    stepper2.setMaxSpeed(500.0);
    stepper2.setAcceleration(200.0);
    stepper2.moveTo(240);
    
    Serial.begin(9600);
    
}

void loop()
{while (Serial.available() > 0) {
    
 
    int xMove = Serial.parseInt();
    int yMove = Serial.parseInt();
    int solMove = Serial.parseInt();
    Serial.print(xMove);
    
    Serial.print(yMove);
    
    Serial.print(solMove);
    
    
    
    
    
    
}
  stepper1.moveTo(xMove*100);
  stepper2.moveTo(yMove*100);
  stepper1.run();
  stepper2.run();
    

}

Please don't ask the same question in two different places.

Ask the moderator to merge this thread with your other one.

...R