Configuring XBEE Problem using XCTU

Dear All,

I am configuring XBEE Modules using XCTU, Facing issue while Reading Modem OR Writing Modem.

Problem : Action Required Dialogue doesn't disappear at any case(while reset)


"Test/Query" & Modem Configuration Read both does not getting response?
I think this is due to : XBee is in API command mode.

How to switch from API mode to AT Mode ?

Please help ....


There's a checkbox on the very first page in the middle. It's labeled 'Enable API' and it set API mode 1. If you want API mode 2, the check box right below it labeled 'Use escaped characters' is the one you want. If you want AT mode, uncheck the API mode one.

However, you should be able to push the 'Test/Query' button and get a good response. Check the baud rate.

Hi All,
I am now able to Test/Query modem.

But, Problem does reproduce with reading modem configuration. Reading produce Action Required Dialogue doesn't disappear at any case(while reset).

Writing modem gives following error :
Getting modem type....Failed to enter command mode
Check Com Port and Baud settings and try again.
Write Parameters...Failed


Is the XBee a series 1, series 2, or series 2.5 ?

Assuming the XBee is already in API mode and series 2 and above, on the first screen, set XCTU to use API mode (Check the box), then go program it to AT mode by choosing the correct firmware, it will get an error, ignore it. Go back to the first screen and set XCTU to AT mode (uncheck the boxes) and then go to the configuration screen and finish programming it. You don't always need to do it this way, but sometimes XCTU needs to be messed with a bit to get it to work.

I am using XBEE Series 2
I have done steps

  1. Set XCTU to use API mode (Check the box)
  2. Then go program it to AT mode by choosing the correct firmware
  3. It gives an error, ignored that error.
  4. Go back to the first screen and set XCTU to AT mode (uncheck the boxes)
  5. Then go to the configuration screen & try to program it in AT Mode

Problem : Action Required Dialogue doesn't disappear

Did you actually reset the board by grounding the reset pin ? I've had to do that a couple of times with a stubborn XBee. I use a jumper wire and touch it to the pin and the sleeve on the USB plug.

If the reset works and the message goes away, then look at the bottom of the XCTU screen for error messages. There's a number of them that can appear there to tell you things. You may well have to do the programming again to make sure the settings get over to the XBee.

But now, just to backtrack: remove the XBee, close XCTU, and start it again. Choose a port in XCTU, plug in the XBee to that port. Do the test query on the first screen, if it doesn't work, set api mode and test query. If it doesn't work, try a different baud rate. If the board is good, and the port is right, you should get a response from the modem and an 'OK' screen from XCTU.

I have also used jumper wire to reset modem.

"Test/Query" : OK without API Mode & 9600 Baud Rate.

I think modem configured in API Mode previously.
Now, I am not able to Re-Configure it with XCTU

Read/Write Modem : Failed to enter command mode
Error : Action Required Dialogue doesn't disappear.

Thanks again, waiting for response...

Hello Again,

I have checked again with another Xbee Base Module.
Test/Query is ok.

XCTU shows COORDINATOR AT Version - 1020 & ROUTER AT Version - 1220 in Modem Config

Reading Module parameters gives OK result in XCTU.
But, doesn't show Modem Type,Function Set & Version.

Writing any value gives error : Getting modem type....OK
Programming modem...Lost communication with modem
Write Parameters...Failed.

Also, Terminal shows - Echo for any typed char.

Interesting info is that :
For 1st Xbee => LED Blinks 2 times per second (I think its Router)
For 2nd Xbee => LED Blinks 1 time per second (I think its Coordinator)

What can i check for communication in this 2 Xbee ?

Yes, the controller blinks once per second and a router will blink twice per second. It's in the XBee documentation.

Since you have two XBees, try programming something into the one that you can read. If it works, then the other XBee may be bad. You can go to the digi site, they have a forum. There are some folk there that know all there is to know about XBees and also the Digi techs monitor the site.

The problem you seem to be having has always been a baud rate mismatch for me. Once I got the correct baud rate, it worked. You can experiment with baud rate on the terminal screen. type +++, wait, nothing happens, try a different baud rate. Echoing in the terminal screen doesn't mean anything except it found the comm port.


In WIN7 :

XCTU shows COORDINATOR AT Version - 20A7 & ROUTER AT Version - 22A7 in Modem Config


XCTU shows COORDINATOR AT Version - 1020 & ROUTER AT Version - 1220 in Modem Config

Does it impact ?

There have been some problems with XCTU and windows 7. I never experienced them I went from windows XP direct to windows 8 and skipped the ones in between. However, the 7 version sounds like it is working better because it gets a firmware version that is correct. Try programming with it to see what happens.

edit: I thought about this a bit and you should be seeing the same firmware version in both the test and the read. The fact that you don't is weird. I don't have a clue why that is happening. Actually, the test button should give you back the serial number of the XBee, is that right, or is there something really weird going on. What I did to prove this on my machine was to plug in the XBee, start XCTU, choose the right port on the start up screen,do the test/query, go to the configuration tab, click read and it just worked. The test query and read both gave me the same version and serial number. Notice also that I didn't set the API checks, or do anything special. Just test, switch screens, read.

I checked and the version I use is in the 5 series ( and I vaguely remember there were versions of XCTU that came out and didn't work very well. You might take a look around a try an earlier version if you can find it.