Confused why this wont work can some one help.

#include "SD.h"
#define SD_ChipSelectPin 4
#include "TMRpcm.h"
#include "SPI.h"

TMRpcm tmrpcm;

void setup() {
// put your setup code here, to run once:
tmrpcm.speakerPin = 9;
Serial.begin(9600);
if (!SD.begin(SD_ChipSelectPin)) {
Serial.println("SD fail");
return;
}
}

void loop() {
// put your main code here, to run repeatedly: song langth 170000
tmrpcm.setVolume(10)
tmrpcm.play("1.wav")
}

error code;

Arduino: 1.8.5 (Windows Store 1.8.10.0) (Windows 10), Board: "Arduino/Genuino Uno"

C:\Users\eatfi\Desktop\song\song.ino:3:20: fatal error: TMRpcm.h: No such file or directory

#include "TMRpcm.h"

^

compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Uno.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

#include "SD.h"
#define SD_ChipSelectPin 4
#include "TMRpcm.h"
#include "SPI.h"

TMRpcm tmrpcm;

void setup() {
  // put your setup code here, to run once:
tmrpcm.speakerPin = 9;
Serial.begin(9600);
if (!SD.begin(SD_ChipSelectPin)) {
  Serial.println("SD fail");
  return;
}
}

void loop() {
  // put your main code here, to run repeatedly: song langth 170000
tmrpcm.setVolume(10)
tmrpcm.play("1.wav")
}

error code;

Arduino: 1.8.5 (Windows Store 1.8.10.0) (Windows 10), Board: "Arduino/Genuino Uno"

C:\Users\eatfi\Desktop\song\song.ino:3:20: fatal error: TMRpcm.h: No such file or directory

#include "TMRpcm.h"

^

compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Uno.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Looks like you havn't added the library to your project correctly.

It looks like you haven't actually installed the TMRpcm library.

DON'T CROSS POST!!!!!!!!!!!!!!!!!!!!

I HAVE REPORTED THIS THREAD TO THE MODERATORS

Threads merged.

TMRpcm.h: No such file or directory

The error message seems pretty explicit. The linker/compiler cannot find the file that you have #included.

Do you have that file and if so where ?
Is the TMRpcm library installed, and if so, how did you do it ?

Thanks a lot reinstalled the library now it works!!