Connecting a Unipolar Stepper to Motor Shield R3

Hi!

I have just bought an Arduino Motor Shield R3 and am having problems connecting a unipolar stepper motor to it. Now I know this has been asked many times and I have searched on Google, but I did not find a clear answer on how to do it and I don't want to misunderstand something while trying to decode other posts and fry something in the process.

Now my first problem is the "cut the Vin jumper". I cannot find any jumper on the back of the shield. Do I have to physically cut something?

am I blind or is there really no jumper?

Next thing is connecting that unipolar motor. The motor has six (6) wires and I don't know where to put the other two wires. I have successfully tested the motor with 4 buttons so I know which wire is which:

CONNECT WHITE AND BLACK TO + (RED)
THE REST TO - (BLACK) IN THE FOLLOWING SEQUENCES:

STEPPING BACKWARD:
/--> YELLOW -> GREEN -> PINK -> BLUE --
<-----------------<-------------------</

STEPPING FORWARD:
/--> BLUE -> PINK -> GREEN -> YELLOW --
<-----------------<------------------</

Motor shield just has
B A

  • | + | - | + | Vin | Gnd

The last thing are motor voltage and current. It says 3.9 V/PH and 1.3 A/PH. What does that mean? Can I interprete this as 3.9V, 1.3A? If so, is it safe to use 5V for it as this motor shield wont work under 5V?

Many thanks for any help given!

Regards, Terraviper-5

Ok, I first tried controlling a DC motor, but connected Arduino Uno to the Motor Shield via jumper wires, not by putting the shield onto Uno since I do not want to destroy the Vin connect "jumper", which as I understand can only be used once, then it is destroyed. It looked like this:

http://shrani.si/f/X/Vy/2GhYfKTF/22112012410.jpg

Problem is the motor did not want to turn with the following code:

int MotorPinDirection = 12;
int MotorPinSpeed = 3;
int MotorPinBrake = 9;

void setup() {
  pinMode (MotorPinDirection, OUTPUT);
  pinMode (MotorPinSpeed, OUTPUT);
  pinMode (MotorPinBrake, OUTPUT);
}

void loop(){
  
    /* --- Forward, Brake, Reverse, Brake Sequence --- */
    //forward
    digitalWrite(MotorPinDirection, HIGH);
    analogWrite(MotorPinSpeed, 200);
    delay(1000);
    
    // brakes
    digitalWrite(MotorPinBrake, HIGH);
    delay(500);
    digitalWrite(MotorPinBrake, LOW);
    
    //reverse
    digitalWrite(MotorPinDirection, LOW);
    analogWrite(MotorPinSpeed, 200);
    delay(1000);  
    
    // brakes
    digitalWrite(MotorPinBrake, HIGH);
    delay(500);
    digitalWrite(MotorPinBrake, LOW);
}

only both lights on A output on the Motor Shield were flashing roughly every second (simultaneously). I connected pins 3, 9, 12 and GND of Uno to same pins on Motor Shield. Are there any other pins that Motor Shield requires or could there be something else wrong?

Thanks!

Ok, I tried it the regular way by putting the Shield onto Uno, the lights on output A are now flashing properly, as the program says, but there is still no power to the motor. I really dont understand what could be wrong. Any help please?

Edit: Ok, I managed to get it to work with one DC motor. But only when the Shield is ontop the Uno. I still cant get it to work via jumper wires. There must be some connections that are necessary but I havent considered them. The reason I want it via wires is also because I need many of the Uno pins for other things, so I cant have them used by the Shield.

I find a system by software for can control one unipolar stepper motor using one Arduino Motor Shield R3

I use this and there are an example of 3 unipolar stepper motors using 3 Arduino Motor Shield R3 into my free APP "Arduino CNC Controller"

In Google Play:

This APP have a Window of "Help and documentation" in witch you can read this source code example

Or you can download on

Terraviper-5:
am I blind or is there really no jumper?

Blind, perhaps?

In your post the words I have quoted are right beside some printing on the circuit board that says "Vin connect"

The motor in that link seems quite large - Nema23, 500grams, 1.3amps. How many wires come from it? I suspect there are 6 wires which would allow it to be used either as unipolar or bipolar. If possible it would be much better to control it with a bipolar stepper driver. See the Thread stepper motor basics.

...R