Connecting Arduino Nano via USB [MAC]

Hey,

I’ve got the same problem.

I Bought two Nanos and connected them with 3 different USB-Calbes.
My Macbook Pro finds the FTDI drivers.

Now I use the Arduino-Programm and can’t upload sketches, that work on the Arduino Uno.
Unless the Arduino shows the dev/tty…-A603RTIG as possible Port.

Basic blinking works on both Nanos.
Hope you can help me out.

The "..." Part of the device name is the critical section. Uno will show up as "usbmodem" and FTDI based devices will show up as "usbserial".

Assuming a genuine uno, there is no common USB hardware between a nano and Uno. So one working really means nothing for the other. They used different implementations.

If I your uno is connected and you see a "usbserial" device, either it is not the Uno or it is not a genuine uno.

I hate repeat but I am having the same problem and I also got FT232R USB UART when running the System Profiler.
However, I am not sure if the FTDI are installed or not, here is a picture to show that the Arduino Nano is showing up.
But when I go to the Arduino Software, it shows no port for the Nano.

Please help and I really want to do some programs on the Arduino Nano.

Screen Shot 2014-06-10 at 9.41.18 PM.png

Same here, no resolution. Summary:

FT232R USB appears in ‘USB Device Tree’, no serial port ever appears in /dev/tty* or /dev/cu*, nor is there anything relevant in via ‘sudo dmesg’, nor does it ever show up in arduino IDE.

I have both latest drivers from http://www.ftdichip.com/Drivers/VCP.htm and have also tried old drivers from arduino 0.2 (though they are the same).

It works fine in Linux. I worry that there is something unsupported in OS X 10.9.3 that does not allow the FTDI drivers to work.

indeed - there is a conflict with 10.9 drivers - see here: http://forum.arduino.cc/index.php?topic=198539.0

unfortunately the solution did not work for me… thus, I’m in linux & works great.

I'm having exact same problem as reported on page 1

The FTDI driver didn’t work for me, too.

But that driver did work:
http://www.prolific.com.tw/US/ShowProduct.aspx?p_id=229&pcid=41

Maybe this will help someone else.
There seem to be some different boards that need different drivers.

Emale, this helped me a lot! thank you so much.

Btw, my system information describes nano as USB-Serial Controller:

and now it's displaying port correctly:

HELP! im having a similar problem, my arduino nano (chinese copy) wont show up on my serial port im getting this information on my system report, i have ftdi drivers up to date and installed… HELP

Have you got a link to where you bought it from? Does it have an FTDI or CH340 chip on it?

it was given to me by my manager, however he told me it was bought on gearbest.com it has a CH340 chip

In which case see this thread here.

Had heaps of problems here, tried the chinese drivers CH341_SER - but as the date suggested (2013) they didn't work with my very late model Mac running 10.10.4. I tried the FTDI drivers and they didn't work either. I had a look and found commercial download (cost about £5) and it worked perfectly (yes I've tested it with a tiny sketch). I'm not working for the commercial firm, and yes I bought a cheap chinese nano - but I've seen heaps of woe on this forum and it worked for me - Drivers are from Repleo and appear as /dev/cu.Repleo-CH341-00001014 on my mac.

YMMV - but I'm sure a lot of folks have given up on this and the device itself works just great - just needs some drivers specially for the mac. I guess XP, Win8 or older macs are probably just fine.

Got the same problem, I bought a nano in GearBest and got one with CH340 driver. Got the driver from: http://www.codenuke.net/2015/01/nodemcu-install-ch340-usb-to-serial-for-yosemite.html and it worked

Hope this one extra step in mac recovery mode terminal might help someone. This did the thing for me)

http://www.homautomation.org/2015/02/05/how-to-use-arduinos-with-ch340g-ch341g-serialusb-ftdi-chip/

I have the same problem with an Imac and El Capitan. I have it with an original UNO R3, I can see the board in the “About this mac” – System report, and also i can see the usb port in the arduino IDE, but when i try to upload, sometimes nothing happen, or sometimes the system do not respond anymore, until i restart.

I have tried to unable de scr protection, install new drivers for the usb, and nothing.

Any help.

Excuse my english, i´m not an english speaker

PD: I have tried with a Pro Mini with the same result

fmod: Got the same problem, I bought a nano in GearBest and got one with CH340 driver. Got the driver from: http://www.codenuke.net/2015/01/nodemcu-install-ch340-usb-to-serial-for-yosemite.html and it worked

Thank you so much! I have tried almost everything with my Chinese nano from aliexpress, and finally drivers from codenuke worked fine!

fmod Many thanks your link http://www.codenuke.net/2015/01/nodemcu-install-ch340-usb-to-serial-for-yosemite.html got the problem sorted.

Same result as neilrcooper... Thank you very, very much fmod. I've been trying to solve this problem for a few days now. Now I can play! :)

Hello! After looking around for a while I found that my Ebay Clone worked flawlessly with this website.

http://arduino.stackexchange.com/questions/13813/arduino-nano-with-mac-os-yosemite-10-10

Hopefully this works for you too.

:)

I checked the USB/Serial chip on my cheap Chinese Nano clone board and found out it's a CH340 (instead of PL2302, used in official boards). Followed the instructions given at http://www.instructables.com/id/Arduino-Nano-CH340/ And downloaded the drivers for my El Capitan 10.11.5 at http://www.wch.cn/download/CH341SER_ZIP.html

Things are working fine now.