Connecting Linino to a 802.1X authenticated WiFi network, as a client

Anyone having success in connecting to a wifi net with 802.1X authentication (username+password)?


Never tried. Have you tried using the advanced control panel?

Sure I tried. It is not supported on LuCI web interface.

I'm not an expert about all the flavours of wifi, but just to be sure: is it a particular wifi security mechanism or you mean that whenever you access this wifi with you computer, the browser shows you a form with user and password fields?
If that's the case, that's called captive portal. There is no common recipe for making the yun work with such portals (everyone is different). You need to mimic your browser behaviour, for example making a sketch that invokes curl with method POST and fields user/password

Nope, that is not a captive authentication. Rather it is a WiFi authentication based on username/password credentials (insetead of having a single shared secret as for plain WPA/WPA2).

It looks like you need wpad and only wpad-mini shows as available on my Yun. You would probably need to compile on your own, here are some instructions Cross Compile [Old OpenWrt Wiki].

Poke around in the OpenWrt world and you'll find more info.

It should work Wireless configuration [Old OpenWrt Wiki] but we still have to set up a test environment and verify if it really works.
You may try connecting to the yun via the ethernet cable connection then play with wifi configuration via "uci" or directly editing /etc/config/wireless

Thanks @Federico for pointing out the right starting page. There is still something that does not work though. After editing /etc/config/wireless I get that:

root@ArduinoPB:~# wifi
command failed: Device or resource busy (-16)
Command failed: Not found
Successfully initialized wpa_supplicant
Line 20: unknown network field 'eap'.
Line 25: unknown network field 'phase2'.
Line 26: unknown network field 'identity'.
Line 27: unknown network field 'password'.
Line 33: failed to parse network block.
Failed to read or parse configuration '/var/run/wpa_supplicant-wlan0.conf'.
enable_mac80211(radio0): Failed to set up wpa_supplicant for interface wlan0

Something not working with the spa_supplicant thing I suppose. It's hard to give you more details, for I have no complete control overt the wifi environment...

Yeah, that's what we got too when we tried to connect to a university wpa2 enterprise. I need to set up a test wireless network and figure out what's wrong