Connecting to Arduino Mega 2560 on OSX 10.10.1 (Yosemite)

I have two Arduino Megas which I have been using fairly regularly. I updated my operating system to OSX 10.10.1 yosemite, and I can no longer program these arduinos. They simply do not appear under the ports menu, and I have no way of connecting to them. Does anyone have any ideas on what the problem may be, and/or what I can do?
(My computer is an Early 2011 Macbook Pro)

I've been trying to solve this for a while, and this is what I've learned:
-My Arduino Uno R3 will still show up under the ports menu.
-The Arduino Megas do not show up using Processing nor under the USB Prober application meaning that it's not just the Arduino IDE.
-I've tried versions 0022, 1.0.1, and 1.5.8
-I have an Ardupilot Mega (APM) autopilot which is based around the ATMega2560 chip. It is not recognized by my computer either.
-Apple made some changes to the FTDI drivers in Mavericks and Yosemite.
-Weirdly, the megas were working for about a month on yosemite before they disappeared from my ports menu.
-I've tried this:
http://forum.arduino.cc/index.php?topic=275934.0
-I've tried using the dmesg command but I don't really know if it worked.
-I've tried to follow this tutorial but did not know what to do by step 5.

Screen Shot 2014-12-22 at 4.10.44 PM.png

Screen Shot 2014-12-22 at 4.15.30 PM.png

I have the same problem.
Tried the same things. No results.

I have Yosemite 10.10.1
MBPro Retina 15-inch Early 2013

I would appreciate all possible help.

Regards,

Same here, worked fine until this morning when i upgraded from 10.10.1 t0 10.10.2.
Anybody found a solution ?

This solved my problem...
I am not sure if all of it or just some part of it, but it solved.

http://www.mommosoft.com/blog/2014/10/24/ftdi-chip-and-os-x-10-10/

Many thanks to the author!

Actually it turned out my board was broken...

Found this link and it worked for me pretty simple How to fix the Arduino Uno Serial Port Problem on Apple Mac Macbook Air - YouTube