Connecting to ARDUINO with W7 64 Bit

I am new in using the ARDUIO. I just bought the ARDUINO UNO, but I can't get a connection to this device.

I am using W7 64 bit. So I installed the driver (2.08.08 ) from the FDTI website. This works fine and I can find the ARDINO UNO in the device manager as “Ardunino UNO (COM3)” .

After this I am struggling with all further operation.

First I started to download a example sketch.
When tying to download, I getting this “Binary sketch size: 1010 bytes (of a 32256 byte maximum)”, but this is the last information for a while. By the way, the green LED on the UNO on, the yellow L is flashing, the RX and TX LEDs are always off.

Sometime I also get the message: “avrdude: ser_send(): write error: sorry no info avail”

Has somebody any idea???


Hi Hans,

Have you followed the instructions at carefully ? the UNO needs other drivers than 328

Furthermore you need to select the right comport in the Tools menu.

Finally you need to select the right board in the Tools menu.

Hopes this helps to get you going!


Hi Rob,

thanks for the fast answer. I think I did everything well.
To double check this, uninstalled the driver and started again. I now installed the driver direct under “..\arduino-0021\drivers” (you mentioned, that the UNO need a different driver than the 328). After doing this, the driver is installed – but the driver can't be started (error code 10). So the diver has still a alert sign in the device manager.

What is the right software for W7 64Bit??? In the download I found the windows software, and below a link to 64Bit, but I don't know, if this means W7 64 Bit or Linux 54 Bit.



Now it is working. I connexted my computer with a other USB port and now everything is fine.
Maybe, that the load on this USB-Port was to high??


I had the exact same issue today and like ours HJB, it started working in much the same way yours did. Then I was able to load some basic example code and I thought everything was great! However, it failed again and I have also tried it on and XP machine, a Windows 7 32 bit and an Ubuntu 10.10 machine all with the same failure to connect. The symptoms are exactly as you describe.

If anyone can assist I would be grateful I don't want to buy a new board, especially if I don't know what caused this one not to work properly after connecting it for the first time today.

One again:
It is working for me, since I am now on a other USB port on my computer. When I am switching back to the previous one, it fails.
So I stiil assume, that the load on the USB port was the problem. So you should try this also.

I did try that. I still get intermittent failure. Interestingly though, I am able to connect occassionally to any given usb port on any of the afformentioned machines. So I now if I am able to connect long enough to load he code I do that and then disconnect. After that I use the 9v battery connection to run the solution. This will become an issue if I need to print output at any point as it just disconnects when ever it seems to feel like it.