Connection Issues

Im trying to connect my GSM 1400 to an azure mysql database. I had it working great, lost the prototype, rebuilt everything, now I cant get any of the sims to connect while in the arduinos.
Ive tried Verizon, ATT, T-mobile, Sprint. each one works in a cell phone but not in the arduino

Any ideas would be really helpful, thanks in advance
-Chris

Modem test
20:54:07.559 -> Starting modem test...modem.begin() succeeded
20:54:11.846 -> Checking IMEI...Modem's IMEI: xxxxxxxxxxxxx
20:54:11.880 -> Resetting modem...Modem is functoning properly

Running the network scanning script I get
20:09:33.780 -> Scanning available networks. May take some seconds.
20:10:08.741 -> > AT&T
20:10:08.741 -> > T-Mobile
20:10:08.741 -> > T-Mobile
20:10:08.741 ->
20:10:08.741 -> Current carrier: AT&T
20:10:08.908 -> Signal Strength: 26 [0-31]

GSM Location script
20:40:49.065 -> Starting GSM location.
20:41:03.345 -> Not connected

TestGRPS script - Ive seached everywhere and tried every APN code I could find
20:44:43.760 -> Connecting GSM network...OK
20:44:56.406 -> Enter your APN: GPRS_APN
20:45:12.334 -> Now, enter your login: login
20:45:21.322 -> Finally, enter your password: Attaching to GPRS with your APN...
20:45:23.669 -> ERROR
20:45:23.669 -> Connecting GSM network...OK
20:45:36.097 -> Enter your APN:

Ping Script
20:48:11.299 -> Starting Arduino GPRS ping.
20:48:24.183 -> Not connected
20:48:38.242 -> Not connected

GPRS UDP NTP Client script
20:49:28.523 -> Starting Arduino GPRS NTP client.
20:49:40.902 -> Not connected

GSM gsmAccess(true); // Connect in debug mode and check what the modem is doing may help

Getting a pile of
22:04:02.881 -> OK
22:04:03.085 -> AT+CREG?
22:04:03.085 -> +CREG: 0,0

Seems to not be registered, Although I know the sim works in a phone and the IMEI of the arduino has been added to the sims registration

Im not sure what to make of this error but it seems to be more relevant to what you mentioned
22:09:54.929 → AT+CGATT=1
22:09:54.929 → ERROR
22:09:54.929 → Not connected

22:04:03.085 -> +CREG: 0,0
is "normal". I added a counter in the gprs lib and sometimes it counts up to 150 +CREG: 0,0s before i get a connection..

From page 13 in the
"AT Commands Examples Examples for u-blox cellular modules"
you will find the commands for further investigation. I think your modem is good, SIM is valid and you can log into your network but can't establish a GPRS connection. Don't get me wrong: Is there still GPRS on your network or 4G UMTS only?

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.