Consiglio IMU

Ciao a tutti! Vorrei costruire con Arduino UNO qualche progetto capace di orientarsi o stabilizzarsi. In particolare, due sono i progetti che vorrei realizzare: 1) un piano capace di rimanere orizzontale qualsiasi movimento faccia il basamento su cui il piatto appoggia;

2) un braccio robotico capace di copiare le inclinazioni che riceve un sensore.

Pensavo quindi di usare un IMU.

Tuttavia non ho una così grande conoscenza in materia e vorrei chiedervi se sto facendo la scelta giusta, a cosa vovrei stare attento, consigli, consigli per un acquisto, ecc...

Vi ringrazio in anticipo!

Ciao, puoi valutare tra le altre la FreeIMU che aveva sviluppato Fabio Varesano. http://www.varesano.net/projects/hardware/FreeIMU

Grazie mille per il consiglio.

Stavo guardando in giro e ho visto anche queste:

SparkFun 9 Degrees of Freedom Breakout - MPU-9150
vedi (https://www.sparkfun.com/products/11486)

SparkFun Triple Axis Accelerometer and Gyro Breakout - MPU-6050
vedi (https://www.sparkfun.com/products/11028)

Adafruit 10-DOF IMU Breakout - L3GD20H + LSM303 + BMP180
vedi (http://www.adafruit.com/products/1604)

Quali differenze ci sono?

Leonarduino87: Grazie mille per il consiglio.

Stavo guardando in giro e ho visto anche queste:

SparkFun 9 Degrees of Freedom Breakout - MPU-9150 vedi (https://www.sparkfun.com/products/11486)

SparkFun Triple Axis Accelerometer and Gyro Breakout - MPU-6050 vedi (https://www.sparkfun.com/products/11028)

Adafruit 10-DOF IMU Breakout - L3GD20H + LSM303 + BMP180 vedi (http://www.adafruit.com/products/1604)

Quali differenze ci sono?

MPU-9159 ha al suo interno Accelerometro, Giroscopio del 6050 ed in più ha un Magnetometro MPU-6050 ha al suo interno Accelerometro e Giroscopio

Sono entrambi utilizzabili con i2cdevlib ovvero delle librerie sviluppate per usare al meglio questi Chip intellisense che hanno al loro interno il DMP un sistema di correzione di errori di Drift sviluppato da Intellisense.

Un consiglio spassionato, non acquistare direttamente da Sparkfun perché paghi anche lo sdoganamento, ti conviene ordinare da rivenditori italiani (Robot Italy o similari)

Grazie mille. Alla fine ho acquistato questo sensore, IMU 9250 - 10 DOF

http://www.drotek.fr/shop/en/home/466-imu-10dof-mpu9250-ms5611.html

E' stato un buon acquisto secondo voi?

La libreria dovrebbe funzionare comunque, giusto? Sapreste indirizzarmi a qualche sito, libro, forum che spieghino che sono le librerie, come funzionano e come gestirle? Grazie ancora!!!

Ciao, direi questi:

http://playground.arduino.cc/Main/MPU-9150 http://www.i2cdevlib.com/devices/mpu9150#source http://www.varesano.net/projects/hardware/FreeIMU#v0.4

ma se digiti mpu9150 su Google ne trovi altri.

Grazie mille del consiglio. Appena mi arriva il sensore lo provo!

Mi è arrivato il sensore, 9250 10DOF di Drotek.
Ho fatto il download sia di FreeIMU che della libreria proposta da Drotek.
All’inizio avevo problemi di caricamento ma successivamente ho aggiunto #include.SPI.h e sono riuscito a caricare lo sketch.

Il sensore l’ho collegato così:

3.3 V ----- VDD
GND ----- GND
A5 ----- SCL
A4 ----- SDA

In allegato ho messo una foto di come lo ho collegato.

Lo script viene caricato ma sul serial monitor compare solo:

Initializing I2C devices…
Testing devic

Non vi sono errori però non ho alcun valore da parte dei sensori…nessun numero…

Che devo fare?
Grazie ancora

20150318_191540.jpg

Ciao, dalla foto vedo che lo hai connesso con cavetti , ti dara sempre problemi di connessione devi saldare una stripline e poi fare il collegamento con i cavetti sulla piastra sperimentale. Questa: Delle 2 librerie quale stai utilizzando ? E poi dacci un link dello sketch che stai provando.

Grazie mille dell’aiuto

Lo sketch che uso è quello scaricabile dal seguente link

Così com’è però mi dava questo errore:

fatal error: SPI.h: No such file or directory
#include <SPI.h>
^
compilation terminated.
Errore durante la compilazione

Allora, aggiungendo #include <SPI.h> ho risolto il problema di caricamento.
Quindi, lo sketch, completo della mia correzione, è il seguente

#include <SPI.h>

// I2C device class (I2Cdev) demonstration Arduino sketch for MPU9250
// 1/4/2013 original by Conor Forde <me@conorforde.com> at https://github.com/Snowda/MPU9250
//
// Changelog:
//     2014-03-27 - initial release

/* ============================================
I2Cdev device library code is placed under the MIT license

Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in
all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
THE SOFTWARE.
===============================================
*/

// Arduino Wire library is required if I2Cdev I2CDEV_ARDUINO_WIRE implementation
// is used in I2Cdev.h
#include "Wire.h"

// I2Cdev and MPU9150 must be installed as libraries, or else the .cpp/.h files
// for both classes must be in the include path of your project
#include "I2Cdev.h"
#include "MPU9250.h"

// class default I2C address is 0x68
// specific I2C addresses may be passed as a parameter here
// AD0 low = 0x68 (default for InvenSense evaluation board)
// AD0 high = 0x69
MPU9250 accelgyro;

int16_t ax, ay, az;
int16_t gx, gy, gz;
int16_t mx, my, mz;

#define LED_PIN 13
bool blinkState = false;

void setup() {
    // join I2C bus (I2Cdev library doesn't do this automatically)
    Wire.begin();

    // initialize serial communication
    // (38400 chosen because it works as well at 8MHz as it does at 16MHz, but
    // it's really up to you depending on your project)
    Serial.begin(19200);

    // initialize device
    Serial.println("Initializing I2C devices...");
    accelgyro.initialize();

    // verify connection
    Serial.println("Testing device connections...");
    Serial.println(accelgyro.testConnection() ? "MPU9250 connection successful" : "MPU9250 connection failed");

    // configure Arduino LED for
    pinMode(LED_PIN, OUTPUT);
}

void loop() {
    // read raw accel/gyro measurements from device
    accelgyro.getMotion9(&ax, &ay, &az, &gx, &gy, &gz, &mx, &my, &mz);

    // these methods (and a few others) are also available
    //accelgyro.getAcceleration(&ax, &ay, &az);
    //accelgyro.getRotation(&gx, &gy, &gz);

    // display tab-separated accel/gyro x/y/z values
    Serial.print("a/g/m:\t");
    Serial.print(ax); Serial.print("\t");
    Serial.print(ay); Serial.print("\t");
    Serial.print(az); Serial.print("\t");
    Serial.print(gx); Serial.print("\t");
    Serial.print(gy); Serial.print("\t");
    Serial.print(gz); Serial.print("\t");
    Serial.print(mx); Serial.print("\t");
    Serial.print(my); Serial.print("\t");
    Serial.println(mz);

    // blink LED to indicate activity
    blinkState = !blinkState;
    digitalWrite(LED_PIN, blinkState);
}

Ho notato una cosa, anche se non so se significhi qualcosa o meno: i led tx e rx non si illuminano una volta completato il caricamento.
Che sia solo un problema di collegamento?

Ciao,
allora i collegamenti li hai fatti per bus i2c o SPI…?

Perché per utilizzare quello sketch i collegamenti li devi fare per bus I2C, sul sito dove lo hai scaricato penso questo: GitHub - Snowda/MPU9250: MPU9250 Accelerometer Driver for Arduino
se scorri la pagina in basso sul Readme c’è scritto chiaramente che non è compatibile con il collegamento SPI, quindi quell’include della SPI non serve.

Altra cosa da fare, lo sketch di esempio funziona con la libreria I2Cdev, quindi devi scaricarla da qui :

una volta scaricata quella che interessa a noi è la cartella Arduino, vai li dentro e cerca I2Cdev, copia l’intera cartella nella cartella librerie di Arduino.
Ti allego un immagine del collegamento ad arduino, ricordati di settare a 0 l’indirizzo della 9250.
Vediamo intanto questo e poi mi vediamo a che punto sei.

p.s: Sai che la scheda ha anche integrato un altimetro… bellina

edit: Guardando lo sketch sembra non utilizzi interrupt dovrebbe funzionare senza …

I collegamenti li avevo fatti seguendo la logica i2c ma davano quell’errore (fatal error…).
Adesso ho scaricato la cartella i2cdevlib che mi hai consigliato e non mi dà più quell’errore, anzi:

  1. non ho più l’errore ISP che mi dava all’inizio, senza scrivere #include<SPI.h>;
  2. il led TX è sempre acceso;
  3. il serial terminal mi da valori numerici

Il problema ora è che qualsiasi cosa faccia con il sensore (ruotarlo, muoverlo, ecc…), il serial terminal mi da solo degli zeri.

Ho letto che dovrei settore a 0 l’indirizzo della 9250 ma, perdona l’ignoranza, non so nemmeno di cosa si tratti.
Come si fa?

Dimenticavo…si, si, al suo interno ho un barometro di alta precisione che quindi restituisce la quota.
Se non ho letto male la precisione è di circa più o meno i 10 cm, quindi una buona risoluzione.

Quando apri il serial monitor blocca lo scorrimento le prime cose che dovresti vedere è una di queste 2: "MPU9250 connection successful" oppure "MPU9250 connection failed".

Nel caso della prima l'indirizzo lo vede e quindi è connesso, allora il problema è da qualche altra parte.

Nel secondo caso hai visto l'immagine che ti allegato sopra nel mio post, dovresti avere 2 piccoli deviatori sulla tua scheda quello di destra devi settarlo a zero, perché lo sketch che stai usando presume che l'indirizzo della 9250 sia LOW = 0.

edit: altra cosa quando apri il serial monitor dei settare lo velocità come quella del tuo sketch mi pare 19200.

Hai ragione: dà errore.

In allegato ho messo un’immagine di quel che si ottiene dopo il caricamento

Ma come si fa a settare? C’è qualcosa da muovere, schiacciare o altro?
Perdona la mia ignoranza ma sono davvero i miei primi passi nell’elettronica.

Ciao,
allora sembra (cosi ad occhio perché non ho quella scheda), che ci siano 2 piccoli switch da spostare con qualcosa di appuntito e fine , quello che interessa a noi è quello di destra che devi mettere su 0.
Oppure sono dei jumper… non so perché dalle foto non si vede bene.

sono quelli quelli che nella foto che mi hai mandato sono tra la parentesi verde o sono quei "cosini" tra le parentesi blu e verde?

Non è che per caso ci debba fare un punto di saldatura per chiedere il circuito?

Si sono quelli a noi interessa il verde, se non si spostano è probabile di si , ma non mi assumo nessuna responsabilità al riguardo :grin:

La stessa cosa allora va fatta anche dove compare la scritta ISP/I2C e dove vi sono le resistenze di pullup?

Mhm.. mi sa di si, almeno da quello che posso capire dalla foto.

edit: Dal forum della drotek sembra proprio che devi mettere i punti di saldatura in quei punti. http://drotek.fr/forum/viewtopic.php?f=10&t=321&p=2066

Pure io sono ritornato sul forum di Drotek e sembra che vadano proprio saldati. Mi resta da capire come.

Facendo anche i2CScanner non trova nulla.