Control flow: Substitute for IF

Hello,

I am making a project that constantly check if the remote control has been pressed.
To check I am using lots of IFs statements...
Is there a better way to check if my IR receiver has been activated?
I don't want my code to have tons of IFs statements.

Thanks...

I don't want my code to have tons of IFs statements.

Switch, with cases, seems appropriate.

PaulsS has made a good guess, but it would help to actually see your code. Please post your code, using code tags (the button that looks like a slash between angle brackets).

If statements don't cost any more money than other statements. Some programs are just that, a bunch of if statements. You can't let it bother you.