Controlling Digital Potentiometer AD5235

I'm not officially lost!

Ive got a AD5235(http://www.analog.com/static/imported-files/data_sheets/AD5235.pdf) for replacing the volume dial in my audio amplifier.

I've got the thing wired up and coded as per this tut - http://www.arduino.cc/en/Tutorial/SPIDigitalPot#.UwdMqHna7wN - but it doesn't work. I see no change on the wiper reading.

I've tried using this one as well - http://www.reigndesign.com/blog/controlling-a-10-bit-digital-potentiometer-via-spi-with-arduino/

And, I've also tried this replicating this once - http://forum.arduino.cc/index.php/topic,85837.0.html

All to no avail.

This is all part of a home cinema project, and everything else is working bar this last bit.

Can someone offer me some support?

Thanks

Martin

So what happens when you try to get it to work.

Did you make sure to pull the CS input on the chip low ?

Did you consider that your AD5235 device is not the same as the AD5206 device in the tutorial ?

Cs pin goes low before sending data each time.

I know one of them was for a 10-bit chip and mines is a 24-bit one, but it thought i'd give it a bash.

I get nothing when i try to get it to work.

As soon as power is applied to the chip the wiper locks at 125(1/2) on both channels and goes full when i remove power, so the chip IS working, i just can't control it.

This is my first time using Arduinos, so not 100% on the art of sending data in bits to devices.