Core 1.0.6 released

Core 1.0.6 for Curie boards (only Arduino/Genuino 101 ATM) has just been released! You can update your existing core via Board Manager

The official changelog is impressive and the tools have been improved too.

For example, the toolchain is now completely targeted to Curie devices (and the specific Intel extensions to ARC core), bringing optimizations and SPEEEEEEED to all your sketches for free ;)

SPI library has been expanded to support the second SPI port routed to the on-board 2MB flash chip, so you can start using it for storage of flash-intensive sketches

From now on, please make sure you are using the latest version before reporting any bug :D

Happy hacking!

Hey, the download for the new 1.0.6 version for the Intel Curie Arduino101 Board will not finish the download. It will get about halfway through and then present the error "Error downloading" Any thoughts?

Ok, I'm a little confused here.

intel's log generated 15 days ago says

  • Remove unsupported SerialFlash example

but then we have serialflash being updated here:

11 days ago

is it safe to use this function?

was intel just removing an erroneous file? or are they discontinuing support for some specific reason?

I’ve tried several times to upgrade v1.0.6 for arduino 101 and it keeps failing with crc doesn’t match error, file is damaged. I’ve even gone so far as to reinstall the entire IDE to 1.6.9 no difference. Any ideas?

Is it possible to install update with Boards Manager in the Arduino IDE? I think that it is what the information says...

I am experiencing issues downloading Core 1.0.6 for Curie boards as well. I tried to download the Arduino 101 drivers through the board manager for both Linux and Mac with no luck. Same error as above.... "Error downloading"

Does anyone have a work around? possibly using Atom PlatformIO?

Also, note that before the error message occurs, the download speed was extremely slow!

Anybody have an idea whats going on?

It look like Intel's servers are really unreliable at the moment, I'll ping them to get some feedback.

If you get a crc error (it means that the file has non downloaded properly) please navigate to your Arduino15 folder (on Win: C:\Users\yourusername\AppData\Local\Arduino15\staging, osx: /Users/yourusername/Library/Arduino15/staging, Linux: ~/.arduino15/staging ) and delete the half-downloaded file, then redownload it from Board Manager

The Intel download site is down most of the time- I constantly get errors from the Board Manager after multiple retries.

This is not acceptable- how does Intel expect the developer community to use their product if the tools are not available ?? They should be working to fix their site instead of spending time on more ads and fancy websites !

I’m in exactly the same situation. 1.0.5 installs fine - but I’ve never managed to get 1.0.6 installed, despite many many re-tries, re-installs, etc. with Board Manager.

Please ping Intel and see what can be done…

I have managed to download

How do I install this ?


Hi Rich.
As an workaround, you can copy your manually downloaded file to


and then try installing via Board Manager again and it should work.

Where are you located? I was able to install several times this morning so either the issue has been fixed or it’s location-specific.


I am still getting "cannot open DFU device 8087: 0aba" on my laptop with windows 10, which only has usb 2.0 ports. Works on my dekstop with windows 7, usb 2.0 ports.

This is really disappointing since this problem has been unsolved for months. I am using arduino 1.6.9 and 1.0.6