Correctly naming my ISR

Hi All,

I've been working through setting up interrupts "by hand" by writing to the EICRA and EIMSK registers. I'm using an Arduino Uno and have the following minimal code example that works:

int pin = 13;

void setup(){
  pinMode(pin, OUTPUT);    
    EICRA=1; //Any logical change
  EIMSK=1; //Enable INT0
}

void loop(){
}

ISR(INT0_vect){ //CONFUSED BY THIS LINE
  digitalWrite(pin, !digitalRead(pin));
}

The question I have is about the definition of the ISR. Through trial and error I found that I had to use "INT0_vect" but I can't find a reference in the ATMega328P datasheet to this string. I found the datasheet here: http://www.atmel.com/Images/doc8161.pdf and if I run a search for "INT0_vect" nothing comes up. The closest thing I can find is "EXT_INT0" on the table on page 66. However, if I use that as an argument in the ISR, the code compiles but the LED doesn't respond. So what source of information should I be using for knowing how to correctly name the ISR? Am I just looking at the wrong datasheet?

Thanks!

http://www.nongnu.org/avr-libc/user-manual/group__avr__interrupts.html

Ah, right... Thanks! So what the interrupt should be called in the ISR is compiler-specific?