"...could not create a folder to store your sketchbook" HELP ME!!

So I'm brand new to Arduino and I get this message every time I try and open the newest software version (0022): "Arduino cannot run because it could not create a folder to store your sketchbook." I have deleted and reinstalled everything several times, tried passed versions of the software, and nothing works. Still haven't gotten the program to open. Please help! I have a secret knock gumball machine just waiting to come to life! Thanks.

sorry, forgot to mention I'm running Mac OSX 10.6.6

Run in admin mode and make sure the folder that your arduino software is in isn't read-only. Not sure if macs have that stuff but I assume they do.

Thanks for the reply. I'm pretty novice with all this stuff, so please anyone correct me if I'm wrong. As far as I can tell, Mac doesn't have a administrator mode. Under the Accounts area of my preferences it has me listed as the admin, so it looks fine to me. When I go to "get info" upon right-clicking my applications folder it says "you can read and write". So, things being as they are, I don't even know what to try and change. Any other ideas?

Alrighty. When you unzipped the .zip, I think it unzipped it with a sketchbook folder. Try moving that somewhere else temporarily and launching your IDE.

Actually, I didn't unzip anything when I downloaded the Arduino software. It came as a .dmg that simply has the Arduino icon, my applications folder, and a driver that I apparently don't need because I'm using the UNO (I tried anyway after a while and it changed nothing). You drag the Arduino icon over into the applications folder, it copies real quick, and that's it. When I search my computer as a whole and the files within the Arduino software (by right-clicking and selecting "show package contents") there is nothing named sketch or sketchbook anywhere.

I really appreciate your help. Please keep coming up with ideas. I'll try anything!

Another note… I’ve come across several people writing in a location for the sketchbook in the preference.txt file manually. I haven’t found anything that works, but I couldn’t help but notice that there is nothing in the preference folder that has “sketch” or “sketchbook” mentioned. Wouldn’t the location of the sketchbook folder be mentioned in the preference code? Does anyone know how to manually fix this on a mac? Am I even on the right path here?

Look in the /Libraries/Arduino for the preferences.txt. It should have a sketchbook.path line; maybe it points to a folder that doesn’t exist? You can either delete the whole preferences.txt or try to manually edit that line to point to a folder that does exist (e.g. make one called “Arduino” in your Documents folder).

Fixed it! My documents folder (which is where Arduino tries to write the sketchbook folder) was set on "read only". There was never any sketchbook line of code in the preferences - not sure why that is, but oh well. Thanks again for your help. Sorry it was such a basic fix.

Hi i am having this very same problem. Please advise: I have the Downloaded zip file (has been unzipped) and running the program i get the same "could not create a folder to store your sketchbook"

i can find the sketchbook in my folder. i understand that its most like set to read only as well but which file and how can i solve this.

Many thanks Adam

I had the same issue. I’m using Arduino 1.6 in Windows 8. I found the preference.txt file in C:/Windows/Users//AppData/Local/Arduino15. Then I changed “sketchbook.path” parameter.

In my case, I think the Arduino IDE was having issues because my Docs folder is redirected to a network share and couldn't figure out how to make a sketchbook folder on "\storage\users(My user name)\Documents\Sketchbook"

Patched by editing the default preferences.txt to read:


and created the Sketchbook folder in the Arduino folder.