Could not load keywords.txt, please re-install Arduino

Hey, so I've been trying to get this to work for months now and still can't figure it out. I get this error message whenever I try to install Arduino on my Windows 10 pro machine via or the windows store.


I have tried uninstalling and reinstalling. I have also purged anything that said Arduino in it from my registry. The only way I can get arduino to work is if I run it in a Virtual Machine.

Any help would be great. I'm aware there are some other posts about this on the forum, but they are outdated and did not come to any solutions.

Hi @clarkjohnathan999. Does the problem still occur after you put the Arduino IDE into portable mode? There are several different keywords.txt files and I'm not sure which one the IDE is complaining about. Running the IDE in portable mode reduces the number of potential keywords.txt files that need to be loaded. So the information about whether or not it occurs will narrow down the source of the problem.

The first thing you will need to do is, if you don't have one already, make a non-Windows Store installation of the Arduino IDE. Due to the additional security restrictions Windows puts on apps, it's not possible to put the Windows Store version in portable mode. You can use the version you get from the "Windows ZIP file" download link on the Software page if you don't want to mess with your existing IDE installation.

In order to put the Arduino IDE in portable mode, just open the Arduino IDE installation folder in Windows Explorer and create a new folder there named portable.

Once that is done, try starting the modified installation of the Arduino IDE and then tell us whether the error still occurs.

Hi @in0

I am having the exact same issue as @clarkjohnathan999

I just tried your suggestion and that has in fact worked on my end and opened the IDE.


I have managed to get an installation working correctly although I am not sure why or how.

After removing anything Arduino related from my PC and downloading the .zip package and installing from there I am no longer getting the keyword.txt error.

Sorry I can't be more informative than that.

Assuming Windows, did you also remove C:\Users\yourUserName\AppData\Local\Arduino15 ? Not sure where the equivalent is in Linux/Mac.

After that a normal install possibly fixes the problem.

Portable installs have their advantages, though.

Hi @sterretje

Yep everything and yes running Windows. Strange one as I have never had that issue in the past and have been running the IDE on the PC for sometime without fault.

Anyway that is what worked for me. Hopefully that might help others. Fingers crossed.

Сработало, спасибо

I have this same issue and anything said in this forum worked for me. I have Windows 11 anyone knows something? Thanks!

Hi @joanpascual. Did you try running the Arduino IDE in portable mode?

I haven't used Arduino for a few years on a couple of computers. Today, I updated to 1.8.19-windows.exe. Now I get the "could not load keywords.txt...." error on both systems that run Windows 10 Pro.

I removed everything related to Arduino, did the uninstalls and reinstalls, deleted Arduino15 directory. Even copied the keywords.txt and preferences.txt to the Arduino15 directory that Arduino creates every time the exe runs.

What is the problem? Why can't Arduino load a file that is located at C:\Program Files (x86)\Arduino\lib\keywords.txt??

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.