Could not write preferences file - Arduino on Windows 10

Hello,

I've installed Arduino 1.8.8 on Windows 10, and when I launch Arduino I get the following error message:

Could not write preferences file: C:\Users\Christophe\AppData\Local\Arduino15\preferences.txt (Accès refusé)

There seems some access rights issue to create the preference file as I get an access denied error. I tried to create an empty file in the directory, I've check if there where any access rights on the Arduino15 directory, I tried to launch arduino in admin mode, but nothing help.

Note that I got the same with Arduino 1.8.7 I tried to install last week.

I'm not installing the windows app version but he version available in download.

Any help would be welcome.

Regards,
Christophe.

This sort of error could be caused by your antivirus software. Try TEMPORARILY disabling your antivirus for a single compilation to see if the problem goes away, then turn the antivirus back on. If the problem doesn’t occur with the antivirus off you will need to adjust the settings of your antivirus to whitelist the appropriate file, folder, or process so it doesn’t interfere with compilation.

If that doesn’t help, the workaround would be to run the Arduino IDE in portable mode. This will cause the preferences.txt file to be located in the portable folder inside the Arduino IDE installation folder. So as long as the Arduino IDE installation is located in a folder with access rights, the problem should no longer occur. Instructions for portable mode here:

Thank-you for your reply, this was indeed a antivirus software issue.

You're welcome. I'm glad to hear you found the solution. Enjoy!
Per