Could you help me hook this VFD up? (solved)

First of all, Hello, Im new here - please dont stab me too much :slight_smile:

Second of all, I have searched a lot regarding this particular VFD and found some good info, but I guess Im just too stupid to hook it up and get it working :blush:

Third, I have an arduino Leonardo (that info might be important :))

Okey, so I salvaged this 16x2 VFD from my old HTPC case. The datasheet can be found here:
It seems to support 3 different protocols - serial, parallel(intel) and parallel(motorola). What the difference between Intel and Motorola is I have no idea :confused:
The default mode was set to motorola, but I have bridged it to serial since I want to use as few pins as possible. The VFD is powered by a PTC PT6314 chip.

And, well, thats about where Im stuck. I cant get it to work :/. Ive tried hooking SI/SO to MOSI, SCK to... SCK lol, and STB(strobe) to a digital pin as instructed in-a-thread-I-cant-find-atm.
I have also tried using the lib found at , as that person has a PT6311-chip(close enough, or so I thought lol), but that doesnt work either...

So yeah... I dont know what I should try next - which is why I turn to you for help :).
Is there any hope getting it to work on my Leonardo, or should I just throw it out the window and save up for an LCD? I dont look to do anything advanced with it, I just want to display temperature from an LM35 sensor. Of course, if I can do some more advanced stuff with it I wont complain :slight_smile: But the main purpose will be displaying temperature.

Im not sure if its allowed to ask 2 questions in the same thread, but...
I also have this LCD with a touchscreen:
Id like to use the touchscreen, but I cant find out how to wire it since it got X1, Y1, X2 and Y2 rather than VCC, X, Y and GND.

Thanks in advance!

I thought I'd be bombed with replies telling me how stupid I am :cold_sweat:

Is the lack of replies due to the question actually being tricky, or is it so stupid no one can be bothered to help? :grin: :grin:

Ah well.. I managed to solve it. A bad solder-bridge was the culprit :roll_eyes: