Couldn't determine program size - compile error

Couldn't determine program size: /cygdrive/c/Program Files/arduino-0008/tools/avr/bin/avr-size: 'C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\build17776.tmp\tomek_7219.hex': No such file

I have tried completely uninstalling arduino, re-downloading it and installing again from scratch, but it still seems to remember my last program used, as it opens it by default on first run. I didn't find any obvious references to Arduino in the Registry, and I deleted references to cygmasomething as recommended elsewhere on this forum, but no luck. Where is this info getting stored (last program saved), and why won't my code compile (just cutting and pasting this:, and including Matrix.h)?

Note that I was able to compile, upload and run a sample led blinker program earlier this week and that all worked fine. As far as I can tell nothing changed between then and now so I'm sort of baffled.

Okay I started a new sketch and copied the code in there and stopped including Matrix.h and it's compiling, now.

okay now anytime i import Matrix.h it gives the error when I try to compile. very frustrated.

Here’s my code:

#include <Matrix.h>

void setup() {}

void loop() {}

here’s the error:

Couldn’t determine program size: /cygdrive/c/Program Files/arduino-0008/tools/avr/bin/avr-size: ‘C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\build27539.tmp\sketch_070715e.hex’: No such file

You probably need to #include <Sprite.h> (above the #include <Matrix.h>). If that doesn’t help, can you post all of the error message you receive? And whether or not the status bar (in the middle of the environment) changes to “Done Compiling.” or not?