Crash creating new arduino sketch with eclipse Sloeber plugin

Have I missed some step? After installing Sloeber plugin, what do I do to create an ESP32 Arduino project?

What I did:

Installing Sloeber plugin on a fresh eclipse installation (as existing eclipse works ok with ESP-IDF toolchain and Olimex ARM-USB-OCD-H debugger).

Windows 7 64 bit.

Installed: Eclipse IDE for C/C++ Developers

Version: 2020-03 (4.15.0)
Build id: 20200313-1211

jdk 12.0.2.

ESP-IDF toolchain already installed and working on command line and eclipse.

Moved new eclipse (because of earlier warnings about paths too long) to: C:/eclipse2

Downloaded arduino-esp32 to: C:/git/arduino-esp32

Created workspace directory: C:/eclipse_workspace_ard_esp32

Installed (from Eclipse Marketplace) Sloeber V4 48.7k version (also tried 17.3k version with same results).

Added c:/git/arduino-esp32 to Arduino > Preferences > Private hardware path.

Clicked Create New Sketch.

Selected platform folder: C:/git/arduino-esp32

Selected board: DOIT ESP32 DEVKIT V1 (also tried LOLIN D2 which works on Arduino IDE):

Core Debug Level: Debug (also tried None)
Flash Frequency: 40MHz
Upload Speed: 115200

Left Sketch template folder as: Default ino file.

(Also tried Sample sketch > Library > ESP32 > Time > Simple Time).

Click Finish:

Error “Failed to create project”.

First part of (pruned) error log attached.


EclipseSloeberErr.txt (3.57 KB)