Create Agent will not run as limited user

I'm running Windows 10. My everyday login is as a non-privileged user (have been doing this for years). I can install Arduino "Create Agent" as a privileged user and can run it. However, if I reboot and login in as my normal limited user, Create agent is not running and I can't use the platform.

If I can't use this platform as my normal login (as I do with all other vendor programs) then I will forget it and try Blynk.

I don't use the web editor but have you tried installing the agent while logged in as the limited user instead of as admin.
You may need to enter admin passwords while doing this but the files should at least install in a folder that is not privileged for your limited user account.

I'm having exactly the same problem as the OP.
I did install the agent while logged in as the limited user, and I did enter the admin credentials to permit the installation. Following the installation (ie during that original installation session) the agent was working, but subsequent logins do not automatically load the agent and when I try to start it from the Windows menu I get the following Explorer.EXE message:
"The item referred to be this shortcut cannot be accessed. You may not have the appropriate permissions."
Will appreciate any clue about what is happening/not happening. :slightly_smiling_face:

I think I've solved it.
I uninstalled the agent and then re-installed it.
During reinstallation I noticed that the files were going to be installed in the local Administrator account's folders (as in 'C:/Users/Administrator/...') rather than my own limited user account's folders.
I changed the installation location to my limited user account's folders and I can now run the agent.

1 Like

Glad you got it sorted.