Custom Arduino Zero not seen by computer under PORTS (COM & LPT)

Hello All,

I have recently assembled a custom arduino zero using an Atmel SAM D21 microcontroller and have SUCCESSFULLY connected it to a friends computer and uploaded the “blink” program to make sure everything is good to go…but I cannot get it to interface with my laptop. I’m using Windows 7 (64 bit) with Arduino IDE version 1.8.2. I have also installed the most recent board driver for the Zero - Arduino SAMD Boards ARM Cortex-M0+. Whenever I plug the board into the USB port, it does not recognize the device. It doesn’t even show up under PORTS(COM&LPT): See Attachment “Port Issue”.

I have tried all of the following:
-Connecting to different USB ports (tried all of them)
-Making sure USB cable is fully secured to board and computer
-Tried older versions of the board driver
-Flashed the bootloader
-Updating Unknown Device Driver by telling it to look for device driver under

  • This results in windows not being able to find the driver software: See Attachment “Driver
    Search Failure”
    -Uninstalling and Reinstalling Arduino IDE and re-updating Arduino SAMD Boards ARM Cortex-M0+

The leds show that it has power when connected.

My friend is currently on vacation an unreachable to try and compare notes on why it works on his computer and not mine. I’m fairly new to all of this so it may be an obvious issue that I am unaware of, but I’ve searched the web for two days now with no luck.

Thanks for your help.

Are you using the same USB cable? You might be using a charge only or defective cable that connects the power but not data lines. Test the cable with another device to verify it works for data.

Hmmm, that is good information to know, but sadly the same USB cable was used with my friends computer and everything worked fine then. This leads me to suspect that it is an issue more with my computer.


I tried it with a different usb cable and still have the same result :(

I used my girlfriends computer to try operating the board--> downloaded the same version of IDE and same driver for the arduino zero. Then the board worked on her computer!!! i was able to upload programs to it successfully. The only difference between her computer and mine is that hers is windows 10 and mine is windows 7.. both are 64 bit.

Upon plugging the arduino back into my computer, my computer recognized it for the first time, and sounded off windows two tones that signal a happy and successful USB device recognition. The device was now visible under PORTS (COM & LPT) as "Arduino Zero (COM 15)".

When I opened up the IDE to load the blink program with my computer, I selected the Arduino Zero (Native Port) as I did on my girlfriends computer (the native port is the one we designed this board to use as we have done for all the other boards in the past that we assembled). I then remember seeing only one port available to select under ports (i dont remember if it was port 15, i just remember selecting it...yes..shame on me). When I proceeded to load the program to the board I heard the dreaded windows two tone noise representative of a device not recognize by my computer (two low freq tones rather than one low and another high); the IDE then displayed a message saying "Couldn't find board on the selected port. Check that you have the selected port correct. If it is correct, try pressing the reset button after initiating the upload" I don't remember which port I had selected, but at the very bottom of the IDE is says "Arduino/Genuino Zero (Native Port) on COM 15", so I am guessing the port I selected was correctly Port 15. Will not see my GF for a week so now way of going back and redoing the process until then.

In Summary: -The board works on other computers -When initially plugged back into mine, it is successfully recognized -When a program is uploaded to it, my computer suddenly can't recognize it anymore -Unplugging it and Re-plugging back in still says it is unrecognizable and considers it an Unknown Device -Reinstalling the Driver does not fix it

Today I downloaded the Arduino IDE on two other computers with Windows 7, downloaded the SAMD boards in board manager, and then attempted to plug my board into the computer. The same issue persisted on both computers. I'm wondering if the board is stuck in a loop that is jamming the serial port so the computer is unable to recognize the board. We have not outfitted the board with a reset button, but even if i reset it, I imagine the board will just get stuck in the same loop again as soon as I try to program it with my computer and then my computer will not be able to recognize the hardware again.

This theory may not be correct considering that when plugging the board into my friends computer, the board suddenly works just fine.

Additionally, I noted that flashing the boot loader to the board does not fix the issue, so would resetting the device do anything different?