Custom board based on ATm32u4 gives "sbdev_open(): did not find any USB" error

I'm working with a custom board based on a ATmega32u4 with a USB connector, and I'd prefer to program it using the Arduino IDE. The problem is that Arduino IDE doesn't see it among the available ports, even though the Mac I'm working on sees the device (see attached screenshot). I'm trying to burn a bootloader.

My first try was with the AVRISP mkll programmer and Leonardo as the target board. I've also tried adding the Cosa library of boards (https://raw.githubusercontent.com/mikaelpatel/Cosa/master/package_cosa_index.json) and selecting the ATmega32u4. All of them give the same error:

Arduino: 1.8.3 (Mac OS X), Board: "Cosa Arduino Pro Micro (ATmega32U4/Caterina)"

/Users/whg2n/Library/Arduino15/packages/arduino/tools/avrdude/6.0.1-arduino5/bin/avrdude -C/Users/whg2n/Library/Arduino15/packages/Cosa/hardware/avr/1.2.0/build/avrdude.conf -v -v -v -v -patmega32u4 -cstk500v2 -Pusb -e -Ulock:w:{bootloader.unlock_bits}:m -Uefuse:w:0xcb:m -Uhfuse:w:0xd8:m -Ulfuse:w:0xff:m 

avrdude: Version 6.0.1, compiled on Apr 14 2015 at 16:30:25
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "/Users/whg2n/Library/Arduino15/packages/Cosa/hardware/avr/1.2.0/build/avrdude.conf"
         User configuration file is "/Users/whg2n/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : usb
         Using Programmer              : stk500v2
avrdude: usbdev_open(): did not find any USB device "usb"
Error while burning bootloader.

Switching programmers only results in a different range of errors, and switching back (as some have suggested doing) doesn't help.

A little help for this stock Arduino veteran, but custom board newbie?

~ W

Screen Shot 2018-08-08 at 2.36.22 PM.png

Hello there!

Can you post the pcb layout file that you made or got?

Absolutely! Here's the relevant portion of the schematic...

BTW, I made some "progress" last night. I switched to a PC, downloaded FLIP, and directed Windows to find the proper drivers in the application's directory. Afterwards the board showed up as an Arduino Leonardo in the Device Manager. I used FLIP to upload some simple "blink" code to the board using the HEX file generated by Arduino IDE, and after a couple of tries it worked!

BUT... after that, FLIP stopped finding any USB devices, even after restart. I tried using Arduino IDE to directly upload to the proper port (since Windows was now seeing a Leo on COM3), but it responded with the error that no board was present on COM3. I'm afraid I've bricked this thing, and I have no idea how.

~ W