Custom Board with FT230XS Not communicating.

I have a custom board I designed and had the PCB made for It is using the ATMEGA328P-AU with 16MHz Crystal and the FTDI FT230XS.
I have flashed the boot-loader and a blank sketch via ICSP. However when I plug the board into USB it is recognized as Basic UART on COM16 however, if I try to upload a sketch via USB I get programmer not responding. Go back to ICSP and it upload the sketch just fine. I have tried selecting Arduino Nano, Arduino Uno, Pro / Pro Mini and even MiniCore (setting the chip and clock) but I still get Programmer not responding. any Idea's? I have tried powering it by putting 10v into the onboard External supply that goes to a SN7805D and Powering it just via USB Still same Error. Tried chnaging USB ports, COm ports and even computers. Any idea's here?

When you do an Upload Using Programmer, it erases the bootloader on the ATmega328P. So after using Sketch > Upload Using Programmer, you need to do another Tools > Burn Bootloader before you can upload via your FT230XS.