Damaged/Faulty Arduino Uno?

Arduino: Arduino Uno SMD OS: Ubuntu 10.10 & Windows 7 Setup: Nothing is connected to the Arduino except the USB cable. Problem: I am unable to upload to my Arduino.

At first my Arduino Uno was working and I was able to upload Blink to it. The problem started yesterday when I plugged in my Arduino and it no longer was allowing me to upload and was giving the error "programmer is not responding" so I tried for a few hours installing different software thinking it was a software issue since I didn't see the driver get loaded in dmesg. Then I tried on my Windows 7 machine, and I get the same unable to connect to Arduino errors (I am able to install the driver and it shows up in Arduino IDE). So I gave up and put the hardware away.

Moving on to today: I plugged in the Arduino to my Ubuntu machine and was able to push the Blink to the unit and it appeared to be operating normally. So then I unplugged it and plugged it back in and now the L led no longer blinks. So I try to push blink to it again and I get "programmer not responding." So I try to reset the Arduino and still I get "programmer not responding." Then I put it down come back a little later and it is working again. Then I unplug it and plug it back in and it stops working and I haven't been able to get it to work since. The only light that is on is the green ON LED. If I put a wire into the Digital 2 port on my Arduino the L led turns solid orange.

Is the unit broken or are there other steps I can try?

I am having exactly this problem with my Arduino Uno on Mac OSX Snow-leopard.

I installed the board according to the manuals and everything was working fine. I got to about chapter 5 in the Getting Started with Arduino book, but after unplugging the board and plugging it back in I got this same error:

avrdude: stk500_recv(): programmer is not responding

And when I check the Tools | Serial port menu, /dev/tty.usbmodem****** the serial port that I connected it to before is gone.

The only serial ports listed are dev/tty.Bluetooth-PDA-Sync dev/cu.Bluetooth-PDA-Sync dev/tty.Bluetooth-Modem dev/cu.Bluetooth-Modem

I've tried removing the Arduino from the device list in networks, but I get no prompt to reinstall it when I plug it back in.

Does anyone have some insight into how to fix this?

Arduino: Arduino Uno
OS: Mac OSX Snowleopard
Setup: Nothing is connected to the Arduino except the USB cable.
Problem: I am unable to upload to my Arduino

I just checked on 2 other OSX machine, installing the Arduino IDE and then plugging in the Arduino Uno board. Neither of the machines recognizes it as a new network interface. Both of them provide power to the board. And the board still retains the same microcode that I had installed on it before and that code still behaves properly, interacting with the breadboard to light up an LED on pin 13 when I hold a switch.

Unless someone knows how to flash this back to factory default, I have no idea what else to do except send it back.

I ran into a similar upload problem recently on Debian Linux 5.0.6 and after perusing the Arduino troubleshooting page at http://www.arduino.cc/en/Guide/Troubleshooting#upload, I resolved it by pressing the reset button on the Arduino Uno directly after clicking the upload button on Arduino 0022. After that the uploads succeeded, so it looks like I only needed to do that once, but please read the upload troubleshooting link for possible tweaks to this procedure and other things you can try.

Since Mac OS X is Unix based, you should see logging in /var/log/messages similar to the following when the Arduino Uno is plugged in and recognized:

Jun 1 23:38:07 spectre kernel: [ 130.543595] usb 1-2: new full speed USB device using uhci_hcd and address 2 Jun 1 23:38:07 spectre kernel: [ 130.739353] usb 1-2: configuration #1 chosen from 1 choice Jun 1 23:38:07 spectre kernel: [ 130.744052] usb 1-2: New USB device found, idVendor=2341, idProduct=0001 Jun 1 23:38:07 spectre kernel: [ 130.744059] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=220 Jun 1 23:38:07 spectre kernel: [ 130.744064] usb 1-2: Product: Arduino Uno Jun 1 23:38:07 spectre kernel: [ 130.744068] usb 1-2: Manufacturer: Arduino (www.arduino.cc) Jun 1 23:38:07 spectre kernel: [ 130.744072] usb 1-2: SerialNumber: 6493534323335171F111 Jun 1 23:38:07 spectre kernel: [ 130.913503] cdc_acm 1-2:1.0: ttyACM0: USB ACM device Jun 1 23:38:07 spectre kernel: [ 130.914834] usbcore: registered new interface driver cdc_acm Jun 1 23:38:07 spectre kernel: [ 130.914839] cdc_acm: v0.26:USB Abstract Control Model driver for USB modems and ISDN adapters

If there are problems with the device, you would likely see them there and may give you something to go by. Note that in this case the device is /dev/ttyACM0. I would be interested to see what it looks like from Mac OS X (presumably you are using "Snow Leopard" v10.6.7?). If you are using the 64-bit version, that may also cause interoperability issues.

I am still having this issue and the troubleshooting Arduino information actually creates more questions than it answers. For example "Make sure there's a bootloader burned on your Arduino board. To check, reset the board. The built-in L LED (which is connected to pin 13) should blink. If it doesn't, there may not be a bootloader on your board."

I don't have a blinking L light so maybe I don't have a bootloader and that would explain why my board doesn't respond when I try to program it. The troubleshooting docs just seem to stop there.

How can I know if I have a bootloader or not? How can I find steps to resolve the issue?

Exact same problem here. I read about the usb to serial converters failing in some newer boards, and tried to reflash it, which worked fine. But the Arduino Uno R3 board is still not communicating. Since I managed to reflash the usb controller, the fault must have occured in the MCU itself, perhaps the Atmega328Ps serial controller has failed. Im going to buy a new board now, and I might just swap the Chips out to see if that is really the fault.