Danno arduino

Salve a tutti , riuscito finalmente a fare tutto quello che era in progetto avevo un sensore lm35 sul dissipatore del regolatore 5v per vedere le temp e inviarle alla pagina web tramite l ethernet. Funzionava tutto quando mia sorella entra in camera tocca un foglio sulla scrivania posto giustamente sotto l'arduino e fa andare in corto facendo scivolare lm35 ("poggiato momentaneamente tra le alette perchè ero andato a cenare mentre era in lettura") con tutto lo scotch che avvolgeva i contatti.
Succo della storia mi è partita la vin ossia quando viene alimentato da vin i led sulla board sono flebili e non si avvia il code mentre tramite usb funziona tutto regolarmente. Online ho letto che puo' essere saltato il diodo , ora mi chiedo dove si trova ?
Io avevo per altro messo un diodo sullo shield per evitare di alimentare l'intera board qualora andassi a collegare l'usb quindi un ulteriore protezione ma aimè niente .....

Qualche soluzione ?

ma lo alimenti dal pin Vin o dal connettore Jack ?

perche' piu' che il diodo sembra che sia partito il regolatore a 5V
Oltretutto dall'ingresso Vin non c'e' diodo di protezione.

Alimentalo dalla presa jack, con un alimentatore da 9 / 12 v e controlla che tensione c'e' sul pin del 5V

Sulla vin ci sono 4.65 volt da usb, praticamente è una cosa strana perchè usb entra si accende tutto doppio lampeggio carica lo sketch e funziona.
Vin si accende il led verde non con molta forza poi dopo un po' in modo flebile il led arancio si accende lentamente ....
Online ho torvato questo:

Ad esempio:
Valore di tensione del led verde tramite usb ho su 2volt e 2volt il led pin 13
Valore di lettura tramite vin 1.91v ali e 1.65v led pin 13

Da jack stessa cosa che da vin non funziona.
La vin con un ali da 12v che senza carico segna 12.6v sulla vin diventa 11.90 volt l'abbassamento è dovuto al diodo m7 (fatto la lettura)

Aggiornamento , si è il regolatore , ho letto sul pin 5v e mi legge 3v come anche sul 3v3...
Cosi sono andato a leggere sul regolatore butta fuori 3volt , è complicato sostituirlo ?
E' il MC33269D-5.0 dove posso reperirlo ? Posso sostituirlo con qualcosa di migliore nel caso ?

Sulla vin ci sono 4.65 volt da usb,

non é un dato significativo.

Per il resto:
Sí é possibile dissaldare lo stabilizzatore 5V e sostituirlo ma poco conveniente e assai difficile. È estrememente piccolo.
Consiglio comprati un altro arduino e usa questo per progettti alimentati tramite USB o 5V.

Ciao Uwe

Non esagerare Uwe, non è così critico dissaldare il regolatore

Stavo valutando l'acquisto dell'arduino 2 in futuro ma questo è un peccato limitarlo all'usb, io mi ritrovo un 7805 ma vorrei rimettere il suo originale o sempre un smd magari con efficenza migliore che scaldi meno, sapete dove posso reperirlo ?

Da farnell

pelletta:
Non esagerare Uwe, non è così critico dissaldare il regolatore

Vero. Il problema è risaldarcelo se uno non sa saldare gli SMD :sweat_smile: :sweat_smile:

pelletta:
Non esagerare Uwe, non è così critico dissaldare il regolatore

Io parlavo di tutto il ciclo; dissaldare lasciando integra la scheda, risaldarlo e non daneggiare ne lo stabilizzatore ne la scheda. Con poca esperienza é un intento non da poco.
Ciao Uwe

uwefed:

pelletta:
Non esagerare Uwe, non è così critico dissaldare il regolatore

Io parlavo di tutto il ciclo; dissaldare lasciando integra la scheda, risaldarlo e non daneggiare ne lo stabilizzatore ne la scheda. Con poca esperienza é un intento non da poco.
Ciao Uwe

Ma non ti conviene aggiungere un LM7805 "in parallelo" al circuito che s'è rotto? OUT dell' integrato sul pin 5V di arduino, GND su GND e aggiungi un jack aggiuntivo volante :slight_smile:

Oppure uno shield su misura con il regolatore e un'area di prototipazione tipo 1000fori.
Anche saldarlo di sotto della scheda sarebbe un'altra opzione.

cece99:

uwefed:

pelletta:
Non esagerare Uwe, non è così critico dissaldare il regolatore

Io parlavo di tutto il ciclo; dissaldare lasciando integra la scheda, risaldarlo e non daneggiare ne lo stabilizzatore ne la scheda. Con poca esperienza é un intento non da poco.
Ciao Uwe

Ma non ti conviene aggiungere un LM7805 "in parallelo" al circuito che s'è rotto? OUT dell' integrato sul pin 5V di arduino, GND su GND e aggiungi un jack aggiuntivo volante :slight_smile:

in ogni caso deve togliere quello guasto, certamente non gli fa bene al 7805; aggiungo per tutti: bisogna avere una discreta mano col solo saldatore per togliere il regolatore considerando che, se ben ricordo, al cs è saldato l'intero corpo, i due pin invece basta davvero sollevarli col saldatore stesso; una possibilità di riparazione sarebbe quella di poggiare il nuovo sopra il vecchio e allungare i pin con due reofori robusti ed il corpo con una lamella, perde in raffreddamento ma in compenso la riparazione si fa in un paio di minuti. :wink:

Michele, non ti contraddici?
prima dici che quello guasto deve essere tolto (che é giustissimo)
e poi consigli di saldare il nuovo sopra?
Ciao Uwe

Calmi calmi haha gia dissaldato 8) 8) Non sono nuovo nel dissaldare e saldare smd , mi riferivo alla posizione in cui si trovava o se hanno usato un particolare stagno per saldarlo. Una volta ho saldato un smd non con un saldatore era una zappa XD.

Allora ho notato solo una piccola cosa , ho messo su un lm7805 avviato si accende poi i led si affievoliscono e si spegne ..... Forse era rovinato quindi aspetto che arrivi il regolatore originale da piazzare su.
Ho notato una cosa pero' se metto con il tester la modalità contatti ossia quando c'è contatto suona e lo poggio sull'out del regolatore e sul gnd fa un breve bip e successivamente mi esce il valore , ergo non dovrebbe farlo essendo separati o sbaglio e alla fine chiude il circuito su gnd ?

C'e ancora dello stagno dove avevo saldato il corpo del lm7805 , ho gia su i punti dello stagno fresco per il nuovo , mi basta poggiarlo scaldare e fine !

Uwe, ho detto che deve poggiarlo di sopra, mica deve metterlo in parallelo, avevo scritto un'istante prima che andavano sollevato i due pin del vecchio, devi stare più attento quando leggi ciò che scrivo, poi ti devo richiamare all'attenzione :wink:
@ ws: non sono molto sicuro che i pin del 7805 corricpondano a quelli del regolatore originale, non è che lo stai usando al rovescio :grin:?

waterseven:
Calmi calmi haha gia dissaldato 8) 8) Non sono nuovo nel dissaldare e saldare smd , mi riferivo alla posizione in cui si trovava o se hanno usato un particolare stagno per saldarlo. Una volta ho saldato un smd non con un saldatore era una zappa XD.

Mica possiamo sapere quanta esperienza di saldatura SMD hai :wink: :wink: :wink:

waterseven:
Ho notato una cosa pero' se metto con il tester la modalità contatti ossia quando c'è contatto suona e lo poggio sull'out del regolatore e sul gnd fa un breve bip e successivamente mi esce il valore , ergo non dovrebbe farlo essendo separati o sbaglio e alla fine chiude il circuito su gnd ?

È normale; hai 2 condensatori da 47µF su Arduino. Quando colleghi il tester per misurare la resistenza i condensatori sono scarichi (percui hanno 0 V) e lentamente con la corrente del Tester si caricano alzandosi la tensione.

waterseven:
C'e ancora dello stagno dove avevo saldato il corpo del lm7805 , ho gia su i punti dello stagno fresco per il nuovo , mi basta poggiarlo scaldare e fine !

Normalmente per fare una saldatura buona - perfetta é necessari aggiungere un po di flussante. Visto che lo stagno ha un anma di flussante basta aggiungere un po di stagnao nuovo mentre saldi.

Ciao Uwe

Si lo so infatti l ho messo invertito haha mi avete preso per un impedito haha XD . Come detto magari non gli piace il 7805 o ancor peggio si è bruciato qualcos'altro anche se mi sembra strano visto che tramite usb funziona sempre e comunque. Una cosa strana che ho notato è che con lm7805 montato messa la usb lo rilevava sul pc poi stessa cosa i led si affievolivano poi non riconosceva piu' la periferica e poi morto , cioè anche se non lo stava usando in quanto la vcc era da usb...

uwefed:

waterseven:
Calmi calmi haha gia dissaldato 8) 8) Non sono nuovo nel dissaldare e saldare smd , mi riferivo alla posizione in cui si trovava o se hanno usato un particolare stagno per saldarlo. Una volta ho saldato un smd non con un saldatore era una zappa XD.

Mica possiamo sapere quanta esperienza di saldatura SMD hai :wink: :wink: :wink:

Sisi lo so ma infatti scherzo logico non mi conoscete quindi non potete sapere :). Ora mi spiego il bip iniziale e la lettura valore invece che 1 , è dovuto ai condensatori infatti mi sembrava strano non ci avevo fatto caso mi son riletto lo schema dell'arduino ne ha 2 sisi.

il concetto è molto semplice, uno che ha le competenze che tu dici di avere NON APRE un Topic per una cazzata del genere, invece ordina il componente, dissalda quello guasto e lo sostituisce col nuovo, senza sputtanarsi col mondo.
A questo punto non si capisce a cosa serve il Topic se ogni cosa che ti si consiglia dici che la sai già e ad ogni obiezione che ti si muove ci dici che non sei un impedito o che altro. Riparati sto benedetto Arduino e buon divertimento. Se poi semplicemente ti senti solo ed hai bisogno di parlare con qualcuno apri un Topic OT e dillo chiaro, ti daremo retta comunque e parleremo del più e del meno....non c'è bisogno di prendere per i fondelli un intero FORUM :stuck_out_tongue_closed_eyes:

waterseven:
Si lo so infatti l ho messo invertito haha mi avete preso per un impedito haha XD . Come detto magari non gli piace il 7805 o ancor peggio si è bruciato qualcos'altro anche se mi sembra strano visto che tramite usb funziona sempre e comunque. Una cosa strana che ho notato è che con lm7805 montato messa la usb lo rilevava sul pc poi stessa cosa i led si affievolivano poi non riconosceva piu' la periferica e poi morto , cioè anche se non lo stava usando in quanto la vcc era da usb...

Non sono sicuro che a un LM7805 poi dare 5V all'uscita. Penso che sia quello la causa dei sintomi descritti.

Ciao Uwe