DC motor with L293D not spinning

Hey, I'm relearning Arduino as I hadn't used it for 2 years due to personal reasons. I'm currently following this tutorial, which has the same wiring as the guide I was provided by my Arduino kit's manufacturer.

Although I have followed the exact instructions, the DC motor does not spin. I've tried the following-
i) confirmed that the components I'm using are not faulty
ii) tried simulating on TinkerCAD, which gives an error

Here's a set of images, which includes:
• TinkerCAD simulation (with code) and error
• Manufacturer's schematic, wiring diagram and example
• My actual circuit

To conclude, the motor works with the above circuit & code for both the Youtuber and the manufacturer but not when I try it on TinkerCAD or with the actual components, and I'm not able to figure out why. Any help would be much appreciated.
Thank You

What error do you get with Tinkertoys? You have links to information that should be posted here, in the thread. I shouldn't have to go off site, and look at a jpeg to see an error message that you can just post.
how-to-get-the-best-out-of-this-forum

The L293 requires 2 power supplies. One for the motor (Vcc2) and one for the internal logic (Vcc1). See the data sheet.

@aarg is right - I'm not going to:
watch a 30 minute video
click links to imgur
wonder what equipment you are using or what your code is.

Just learn how to use the forum to help US help you.