DCcEle Dccduino Uno problems

Hi

I bought these cheap Uno clones (serve me right)

http://www.ebay.co.uk/itm/281554135897

They are called DccEle DccduinoUNO

I can’t upload to them using Windows 7. I have installed the driver, which seems to be OK in the Control Panel. The PC seems to recognise them (they have a port number). But I cannot upload a blink sketch - I get the
avrdude: stk500_getsync(): not in sync: resp=0x00
message.
I am assuming they should be selected as Uno on the drop down menu.
Any ideas?

OK... so have you downloaded the CH340 drivers?

If you have, with the Uno unplugged, look under Tools-Port and wee what ports are available.

Then plug it in, give Windows a whole minute (On Linux it is much quicker) and check again.

If you have no new port, the drivers are not loaded. If you have a new one, that is the port the Uno is on.

Yes I have downloaded and installed the CH340 drivers, and yes the port only appears when the Uno is plugged in. But I can't upload anything.

Can you try the loopback test at the top of the forum.

Out of interest where did you get the CH340 drivers from? There are a couple of places around that have out dated drivers. The manufacturers drivers for the CH340 are here.

No, it's failing the loopback test.
I got the drivers from here

  • are these ones up to date?

No idea. Get them from my link, they are, it is the CH340 manufacturers website.

Uninstalled, reinstalled from that link - no change.

Is it still failing the loopback test?

Yes. will try on another pc

I don't suppose you have anything running Linux to try it on?

No … I tried it on another PC with the same result. The X1 LED flashes a little when I try to upload but nothing more.
I am fairly sure the drivers are installed OK because I managed to get a Dccduino Nano to work OK, using the same drivers (I presume).
Thanks for helping but I think life’s too short to sort this one - I may as well get a proper Uno.

We sell and use that variant and have not (as yet) had any issues.

Have you got access to a Linux box or a live CD? If so you could check how it comes up in Linux.

I have read the postings and would like to help. In late December 2014 and early January 2015 a batch of DCcduino Uno R3 boards where produced and have been being dispatched without the boot loader installed. I would suggest that the board in question is one of the boards without the boot loader.

Thanks - can I load the bootloader? I tried “burn bootloader” but got the famous
avrdude: stk500_getsync(): not in sync: resp=0x00

You need to use another Arduino board to burn the boot loader. You could also raise the issue with the vendor.

From what you have posted in the past I believe you have a Nano. You can use the Nano as a programmer by making it an ArduinoISP and connecting it to the Uno via the ISP (6way Header). I have used this method on a few occasions to correct boards without bootloaders or to program new Micros for other people.

The following link is from Sparkfun and it should give you an idea of what is required.

https://learn.sparkfun.com/tutorials/installing-an-arduino-bootloader

The Sparkfun information shows connecting to Unos together but this can be easily changed to be a Nano and Uno.

The main thing to note is that the Nano would first need to be programmed with the ArduinoISP sketch located in the examples menu. I would recommend that you program the Nano with nothing attached to any of the I/O pins. The ArduinoISP sketch contains the pin connections required (10 thru 13), however you will need to power the Uno from the Nanos 5V & Gnd as well.

Once every thing is connected, link the Nano to the computer, check the Com port settings match the Nano, set the board type to Uno (this is because you are programming an Uno), set the programmer type to Arduino as ISP, then click Burn Bootloader.

Thanks - will look at that. I have more working Unos so shouldn’t need to use a Nano.

I use Nick Gammon's sketch here.

hello,,
for the DCcEle Dccduino Uno problems just download drivers for the CH340 drivers for USb and Arduino zip file...

make a connection between arduino and PC..

I am talking about windows XP....download arduino version 1.0.4 and go to tools select arduino Uno then just upload the led Blink program to the same board...