Dead YL38 soil moisture sensor?

Hi. I was wondering if someone could confirm to me that my FC28 has died (EDIT. I realized its YL38!! not FC28, sorry!). When I power it on it turns on two red LEDs, which is weird as I remember it used to be only one LED on. And then, when I try to get readings from it, I always get 0v. Is it broken? should I just throw it away? Thanks a lot!!

You get 0V when the sensor is in water and you get 0 volts after removing the sensor and drying it off?

My reading of the information about the FC28 is this: If the sensor detects low moisture the LED is red, medium is green and high moisture is blue. .
So, red and red are correct. Put the prob in medium moist soil and get green and high moisture you get blue.

What did you actually do to test the device? Without you disclosing that, how could anyone confirm anything?

Paul

I found several different sensors with that number. It always helps to post a link to the part you have. Since it measures resistance and the pads are exposed it could be "worn out" as the pads do corrode. Not knowing how it is connected I cannot offer anymore information. Post a schematic would help as I have no clue as to how it is connected.

Hi,
Can you please post a picture of your project and a circuit diagram?

Thanks.. Tom.. :grinning: :+1: :coffee: :australia:

I get 0v all the time, no matter where I put the prob in... thanks!!

It seems there are many kinds of FC28, my bad. This one I never saw a colour different than red in its two LEDs. As I said It used to be only one LED on but now its the two of them all the time in red. I found this about the LEDs:

  • Power indicators: (red) and digital switching output indicator (green).

I never used the digital output and never saw a green light. I wonder why its red now.

Its really easy to test just power with 5V between Vcc and GND and to read the analog output using the "AnalogInOutSerial" example. I get the same 0v. I've switched to a potenciometer measuring the same analog input and I get nice readings... back to the sensor and get 0 and 0 and 0...

I gotta apologize I've said it was FC28 but looking close the board it says YL38. I'm sorry for the missunderstaning!! (They look the same I don't know what's the difference). It looks exactly like this one:

hygrometer3-1_Z123DR5BSY

I think this sensor may be broken, I just had never seen one broken before and I thought someone could recognize the 0v all the time behavior or the double red LED all the time. This sensor is pretty cheap so I'm thinking about replacing it and to see if it goes well with a new one..

This description of the YL38 and how it operates seems to indicate your device is working properly.
Please study this link.
The output is STRICTLY digital, 0 or 1.
Paul

Hi,

And you adjust the on PCB trim pot to get your change over point.
Have you tried adjusting the pots on the "faulty" units.

Place the pot in the same position as the good units.

Yes but do you actually place the sensor in and out of water?

Thanks.. Tom... :smiley: :+1: :coffee: :australia:

Hey thanks. Yes, I've readed the link; I don't understand why the autor makes such analysis. Please read other sources there are many that grant A0 as an analog output. I've used this sensor for years, its just failing now..

https://randomnerdtutorials.com/guide-for-soil-moisture-sensor-yl-69-or-hl-69-with-the-arduino/ YL-69 (Probes) YL-38 (Interface)

The output can be a analog signal and so you’ll get a value between 0 and 1023.

Hi, thanks.

I'm not using the digital output, only the analog one.

Yes sir I tried in dry soil, in water, wet soil, into "the air", it all measures 0. I'm using the A0 so I'm specting a reading between 0 and 1023 ... as I did with the same sensor in the past.

Hi,
This is supposed to be the schematic.


If you are using the analog output, this appears to be a very high impedance output.
Can you try these 2 tests
1)
With the sensor unit disconnected, but sensor probes connected, measure the resistance between the devices A0 output and its GND with DMM
Measure both ways with OHMs range.
2)
If you replace the probes with 10K resistor what analog measurement do you get?
Measure the voltage across the 10K.

Thanks.. Tom... :smiley: :+1: :coffee: :australia:

That information would have been great to have on post#1. Here 'we' been thinking new installation; OK, so I was. Now I read the things been in service for years. Most likely, you suspected the sensor was bad; another bit of first post info you forgot to add. Stop this madness. The sensor is bad. Get a new one.

Thanks.

Hi, I'm sorry I forgot to mention that. I mean most of the time it has been saved but yeah its an old sensor.

It was implied when I said (in the very first sentence):

I was wondering if someone could confirm to me that my FC28 has died

Yes sir, thanks a lot. I'm sorry if it was an unnecesary topic.

1 Like