Default settings of Timer0

I have changed the default settings of Timer0 in Arduino UNO, that affects millis() and delay() .
now They counts time slower than normal .I have tried to fix this proplem by burn the bootloader but Aduino IDE shows "Error while burning bootloader."
what can i do to fix this?

These settings are reset to the defaults at each reset. So if you did not modify the base code in your IDE the correct values will be set every time you upload a new sketch.
To burn a bootloader you need a programmer. I guess you did not connect a programmer to your PC/Arduino, did you?