Desktop Ide not working with Arduino Due

Iam having a strange problem with Desktop Arduino Ide and Arduino Due. I can't upload my sketch. the board is installed ok and the driver too.
Iam using Arduino1.8.2. when I attempt to upload the message

"No device found on COM11
An error ocurred when uploading the sketch"

Here is the strange thing. I have tried with Cloud Ide Arduino Create and it works OK!!
Uploads normally and run ok.
So my hardware is ok.
I can ever use the serial terminal.
The problem is with the Desktop Ide. Any clue?

I have tried with another pc with W10 and arduino 1.6.8 and works ok. maybe a problem with Arduino 1.8.2 build?

From your post in a different thread.

I have not seen your reply. the ports are ok. Ive tried both ports and both failed. but with cloud's create everything works ok. As I said, after programming with create I can turn to desktop and use the serial terminal.
I've tried another pc with W10 and Arduino 1.6.2. and works ok. so it seems problem in the 1.8.2build.
sorry for opening another post

Pert responded with make sure you select the right port. He was NOT referring to the two USB posts on the DUE.

Open your sketch, with your DUE connected via the programming usb port. on your IDE Tools> port and select the port that is obvious EG Port3 See attached image

Yes the port config is ok. is just the same config I have in another PC with W10 and Arduino 1.6.2 working ok with Arduino Due Board. I've tried both ports