Detect and correct FT232 "soft" brick?

Is there a reliable way to correct a “soft brick” of my Arduino Nanos? I have a string of five instances where the Nano is seen by Win7-64 on the first try, but after programming it once, Win7 says “can’t load drivers.” This has happened now with five Nanos in a row.

This is today. I haven’t been programming my Arduinos for the past three months, so the “soft brick” driver, if it installed, should have been removed automatically. This is after using the FTDI CDM removal tool and back tracking to driver version 2.10. I thought the Windows update fixed the FTDI problem back in late October.

should have been removed automatically.

You'll want to check the driver version manually. I dug up my W7 laptop, just to see how it would behave wrt FTDI drivers, and here are some of the things I found:

  1. I don't think windows will "revert" drivers to an earlier version, just because the update is remove from distribution.
  2. "uninstall driver" doesn't seem to remove the new driver from disk.
  3. There's an "optional windows update" published 11/7 that claims to be something FTDI-related, but on my system it fails to install. Usually with an unknown error code, but at least once with an error code that said "a newer driver is already installed."
  4. Even if I manually installed 2.10, windows happily upgraded to 2.12 from late august, automatically, when I plugged in my arduino.
  5. It did that even if I deleted the files that Device Manager claimed to be associated with the port.
  6. Eventually, I got it to stay at 2.10 by doing a manual "update driver" from the device manager and "Let me pick from a list of drivers" (2.10 was in the list after doing the manual install from ftdi's 2.10 download.)

Grr.

Dug out an XP machine, loaded IDE 1.0.6, and still no com port. I tried installing the driver in the IDE "Drivers, FTDI" folder, but Windows says "The specified location does not contain information about your hardware." This was after I had selected Universal Serial Bus as the component and ftdibus.inf as the associated file.

I'm out of ideas.

Have a look at this video and instructions on this thread.