/dev/tty.ARDUINOBT-BluetoothSeri-1' already in use

Hi,

Today I have been trying to get my Arduino BT to my MacBook Pro, which runs OS X 10.4.11.
This attempt resulted in lost of many hours and browsing the entire troubleshooting section.

I got this far:
I managed to have the ArduinoBT connected with my Mac. When I push the upload button and directly push the reset button; my bluetooth panel says the ArduinoBT is connected.

However, the program cannot be oploaded to the ArduinoBT, apparently because the following error message keeps popping up:

“Serial port '/dev/tty.ARDUINOBT-BluetoothSeri-1 already in use. Try quiting any programs that may be using it”
at processing.app.Serial.(Serial.java:140)
etc.etc…

Because I am not running anything else except for the Arduino 10 IDE, I think this error message is quite awkward.
I found a post discussing the similar problem. (http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?action=print;num=1201228650) The solution, given by Mellis, was to copy the librxtxSerial.jnilib into the system/library/java/extensions directory.

Unfortunately this did not solved the problem in my case. Could someone please help me and others who are struggling with the same problem out? Appreciate it!

Best Regards, :wink:

Chao -
Interaction Designer, Philips Design, Eindhoven

That was my post and it fixed my problem, however I was not using bluetooth.

Have you installed any javax.comm or com.rxtx stuff on your mac?

I did because I'm a java developer, the default for rxtx is the use lock files to control ownership of the serial port. This caused problems for me, however the com.rxtx libraries included in arduino, have the lock files turned off(thank you mellis).

When I replaced the files, my arduino was better.... simply got the right native libs loaded.

you might want to search for any other installations of serial drivers

as root run the following command "find /System -type f -name "librxtxSerial.jnilib" if you don't find anything its likely a different problem.

There's a similar thread going on here:-

http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1201091018

The exception I'm getting, sounds identical to yours chao, I tried all the suggested fixes too and nothing works also.

I never found a good solution for the BT on Arduino 0010 but it works fine for me with the pre-release of Arduino 0011. See http://tinker.it/now/2008/03/18/making-sense-of-the-arduino-bt-and-mac-os-x-leopard/

//erik