Devduino sensornode v2 can't go to 8mhz, can't upload via serial

Hi, i have tried to upload a new boot loader on the Devduino Sensonode
http://www.seeedstudio.com/wiki/DevDuino_Sensor_Node_V2.0_(ATmega_328)

I used a spark fun tiny programmer
https://learn.sparkfun.com/tutorials/tiny-avr-programmer-hookup-guide/?_ga=1.20253371.2008081562.1422476468

i tried to upload a boot loader of the arduino pro 8mhz and i also have uploaded my sketch via the programmer.
I instantly noticed that the led was blinking twice as fast, so the Atmega was running at 16mhz and the compiler have sent the sketch for 8mhz (right?) but the boot loader writing completed without errors.

So i tried to flash the Sensornode with various other boot loaders, like the 328 on a breadboard (8mhz) and other, lastly i flashed it with the “original” pro mini 16mhz.
I then noticed that i can’t send a sketch to it via serial, it says that the programmer is not responding (it was working before the bolted change).
I then tried various boot loaders but i can’t get the serial upload to work, i can only upload sketches via ISP by the usb tiny programmer.

Anyone have an dea of why this happens?
i really don’t mind of being unable to upload via serial, my goal is to have it run correctly on 8mhz even better with a brown out of 2.4v (i have a setting for that, but the sketch runs at double speed, so the nrf24 can’t work).

Thank you!

With the newer IDE if i upload the uno boot loader i can also upload via serial, but in that IDE i don't have the settings for the 8mhz, i see it's different and has all the files in the package (os x)

Other strange thing is that loading the boot loader in the 1.6 is incredibly faster, like 2 secs instead of maybe 30-45 of the older versions... initially i was thinking that it was making nothing and just saying "done" :astonished: