DFRduino Duemilanove stopped working over USB w/ Win7

Hi,

I recently purchased the DFRduino Duemilanove which is 100% compatible with original Arduino Duemilanove (DFRduino Duemilanove 328 (Arduino Compatible)-DFRobot).

I was playing with it yesterday and tested some small circuits with leds and a photo transistor, all good so far (even got it running as intended). Then suddenly I was unable to upload sketches, the COM port had disappeared from the menu in Arduino IDE. I tried unplugging the device and when i put it back in Windows displayed the error “One of the USB devices attached to this computer has malfunctioned and windows does not recognise it". I now get that error whenever I connect the Arduino to my pc.

In the Device Manager the Arduino shows up as "Unknown Device" when connected via USB. I've tried to uninstall it, reinstall driver and reboot Windows a number of times without any luck. I've tried different USB ports and swapping USB cable (some other forum posts have had same issue with faulty usb cables). If I try to update the driver Windows says that it already has the best driver installed for the device.

I've also run through the trouble shooting guide and tried to perform the loopback test, but that test assumes that Windows finds the Arduino which is not the case for me.

I also noticed that nothing appears to happen when I hit the reset button; no on-board leds flashing, although I'm not sure if that was the case before my issue started though). The last sketch I uploaded before problem occured is still working when i have the components wired to the Arduino.

I've been trying to backtrace my steps, and the only things that I could think of as possible causes are:

  • I hooked the Arduino up to external power (9V 1A) which according to supplier should work fine with Arduino: http://www.robonor.no/mag/default/arduino/stromforsyning/arduino-9v-1a-high-quality-dc-power-adapter-vde.html. I may have had it connected when usb cable was also plugged in, but not sure. I think this is when the USB problem started, yet not entirely sure.
  • I have occationally hit ctrl + shift + u (Upload using programmer) instead of ctrl + u, but I don't think this is a likely cause as I did this accidentally on several occations yet normal upload (ctrl + u) worked fine afterwards many times (Arduino IDE just printed an error to the log).

When I connect Arduino to the PC the following happens:

  • Power led goes on
  • tx + rx leds both flash 6 times, first 2 quick followed by a short break and then 4 blinks which has a slightly longer pause in between them compared to the first 2 blinks
  • Windows shows the error “One of the USB devices attached to this computer has malfunctioned and windows does not recognise it" but my sketch still works

I tried connecting the Arduino to another PC which didn't have the driver installed, after installation it displayed the same error.

Also, I've noticed that the Arduino is very warm around the USB and power connectors. I'm new to Arduino and don't know if this is normal. The heat seems to come from two black components (voltage converters?) between power and USB connectors.

Any thoughts?

thanks,
Geir

I just got hold of an Uno which I used to re-write the bootloader onto the dead Duemilanove, and after that I can see the board on my pc again. uploading schetches still fails, but I was fortunate to just have some Atmega328 IC's arrive in the mail and after making the switch, all was back to normal again.

Not sure how/why the bootloader needed to be rewritten, or why it still didn't work entirely until I replaced the chip. If anyone has clues, please share them, I just want to avoid bricking another atmega chip (I only have so many..)

I'd also like to know if someone has a response to this.

I've just recently had some similar problems with a Mini Pro 3.3V Arduino (uses the Atmega328P). I've been working on getting familiar with the Arduino/Atmel platform and I wanted to prototype a device. On a whim I decided I wanted to try and program the Mini Pro using the AVRISP mkII that I have available using the Arduino IDE rather than the FTDI cable. I managed to get the Mini programmed using the AVRISP. I also decided to try this with a Duemilanove board as well, which also was successful. However, I wanted to go back to using the FTDI cable I was originally using. I learned I needed to reload the bootloader otherwise I couldn't use the standard IDE functions. So I installed the Atmel Studio 6.0 and got the requisite installation setup and reloaded the bootloader on both the Duemilanove and the Mini Pro. Only the Duemilanove will accept sketches anymore. The Mini Pro gets the following error whenever I try to upload a sketch: avrdude: usbdev_open(): did not find any USB device "usb".

For testing purposes I took a second Mini Pro and tried re-uploading the bootloader onto the device. I verified before doing this that the board would work with a standard sketch upload, which it did. Now however, after loading the bootloader it too will not upload sketches. I've gone through and verified that the problem isn't with the FTDI cable or USB drivers, as I have a third Mini Pro that hasn't had anything done to it that works just fine when uploading a sketch to it.

It seems like there's something going off the rails involving mucking about with the bootloader upload. Unfortunately I'm now out two Mini Pro boards unless I want to order raw chips and try reflowing new ones onto the boards to see if I caused a chip failure somehow. Even then I might as well just order two replacement boards.