DHT22 - Plötzlich Fehler beim sketch hochladen

Hallo miteinander!

ich habe eine Temperatursensor DHT 22 und ein Ardulino Nano mit dem beiliegenden Skech immer problemlos zum Laufen bekommen. (IDE 1.8.5)

[Sorry - habe noch nicht heraus gefunden wie ich einen sketch hier als Fenster in den Text einfüge :frowning: ]

Jedoch jetzt auf einmal funktioniert es nicht mehr - es zeigt immer beim hochladen „Fehler beim Kompilieren für das Board Arduino Nano.“
Wir haben es auch mit einem anderen Laptop mit neuester IDE 1.8.9 und aktuellen Bibliotheken versucht. → Selbe Fehlermeldung.

Dto. wenn wir einen UNO anschließen und die IDE entsprechend umstellen → „Fehler beim Kompilieren für das Board Arduino UNO“

Kann uns jemand weiterhelfen. Wir sitzen hier am Lago Maggiore; machen einen Adruino Privat-Workshop und wollten die Temperatur messen.

Gruß Martin und Tobi

DHT22_LCD2.ino (1.48 KB)

Hi

Nun denn - da wird der Kompiler wohl irgend einen Fehler anmeckern.
… Welchen überhaupt ??

DAS kannst Du herausfinden, wenn Du Dir die vollständigen Meldungen ausgeben lässt - sind in den Voreinstellungen zwei Haken, Die ganz gerne gesetzt werden wollen (wo nur der Herrgott selber weiß, warum Diese standardmäßig abgestellt sind).

MfG

Edit
Kompiliert (sogar ohne eine einzige Warnung) - wenn man die verwendete Library in der IDE eingebunden hat.

// Test Programm von TR mit LCD Display - abspecken!
// Jb - 12.04.2019 - läuft!!

#include <SimpleDHT.h>      //Fügt DHT22 Libary ein

#include <LiquidCrystal.h>                  // läd das LCD-Programm (library code)
LiquidCrystal lcd(12, 11, 10, 9, 8, 7);  // definiert die LCD pins / Anschlüsse am Arduino (rs, enable, d4, d5, d6, d7)

SimpleDHT22 dht22;        // Typ DHT22 zuordnen

float h = 0;   // Variable für Luftfeuchtigkeit definieren als "float" (Fliesskomma Wert mit Nachkommastelle.von -3.4028235E+38 bis 3.4028235E+38)
float t = 0;   // Variable für Temperatur definieren als "float"

void setup()
{
  pinMode(6, INPUT);             // pin 6 als Eingang (DHT definieren)
  lcd.begin(16, 2);              // Display mit 16 Zeichen - in 2 Zeilen
  lcd.clear();                   // Display löschen
}

void loop() {

  int err = dht22.read2(6, &t, &h, NULL);
  if (analogRead(A0) > 500)      //  if(err != SimpleDHTErrSuccess) Fehler mit Taster an A0 simulieren!
  {
    lcd.setCursor(0, 0); lcd.println("Read DHT22 fail  ");   //  Serial.println("Read DHT22 failed, err= "+err);
    lcd.setCursor(0, 1); lcd.print("err= "); lcd.print(+err); lcd.print("           ");
  }
  else
  {
    lcd.clear();
    lcd.setCursor(0, 0); lcd.print("Temp."); lcd.setCursor(8, 0); lcd.print(t); lcd.setCursor(12, 0); lcd.print("  "); lcd.write (223); lcd.print("C");
    lcd.setCursor(0, 1); lcd.print("Feuchte"); lcd.setCursor(8, 1); lcd.print(h); lcd.setCursor(12, 1); lcd.print(" %rF");
    delay(2000);  // 2 Sekunden Pause
  }
}

Wuehlmaus:
[Sorry - habe noch nicht heraus gefunden wie ich einen sketch hier als Fenster in den Text einfüge :frowning: ]
.....

Wie.....3 Jahre dabei und das geht immer noch nicht.

Einfach mal lesen: how to use this forum

Hallo Gemeinde!

-> postmaster-ino : Wie Du vorgeschlagen hast -> so ziemlich alle Häkchen gesetzt -> in dem Wust der Fehlermeldung stand dann auch folgende Zeile „file or directory SimpleDHT not found“ -> also im Bibliotheksverwalter nach „SimpleDHT“ gesucht & gefunden - aber dann nochmals installiert

-> Jetzt klappts! :slight_smile: :slight_smile:
Aktuell am Lago Maggiore in Cannero 13,9°C, 81,5% r.F., (->Regen :frowning: )

Lag also gar nicht am Board selbst – alle anderen Programme konnte ich ja schließlich auch problemlos hochladen - wie so oft ist die rote Fehlermeldung nicht die wirkliche Ursache!

-> HotSystems : Ich werte das mal als gutes Zeichen – seit 3 Jahren am basteln und diese Funktion noch nie gebrauch!

Damit ich es lerne hier ein kleiner sketch der nix mit dem Thema zu tun hat – also nur übungshalber - aber...

// Schaltet pin als Ausgang Low / High alle x Sekunden => Blinken
// Jb 22.04.2019 / läuft !!

void setup() {

  pinMode(13, OUTPUT);  // setzt pin´s als Ausgang
  pinMode(8, OUTPUT); pinMode(2, OUTPUT);
}

void loop() 
{
  digitalWrite(13, HIGH);   // schaltet Ausgang HIGH (LED ein)
  digitalWrite(8, HIGH); digitalWrite(2, HIGH);
  
  delay(5000);              // warten für x milli Sekunden
  digitalWrite(13, LOW);    // schaltet Ausgang LOW (LED aus)
  digitalWrite(8, LOW); digitalWrite(2, LOW);
  
  delay(5000);              // warten für x milli Sekunden
}

…. obwohl mich das bei meinem Arduino-Privat-Schulungs-Workshop gestern auch zur Verzweiflung getrieben hat: Bei LOW messen wir 2,6 V ?!?!, bei HIGH 5V (so wie es sein soll).
Board: Arduino UNO,
Beschaltung: keine (also Borad „nackig“),
Spannungs-Versorgung: über USB.

Heute funktioniert es plötzlich – schaltet 0V und 5V an allen 3 Ausgängen hin und her :confused:
Vielleich sollte man als Anfänger keine Einsteiger-Kurse für interessierte blutige Anfänger auf dem Campingplatz geben...

Gruß Martin

Falschen Campingplatz ausgesucht. Hier Tröpfeln bei 16°. Gestern 24°C und 11h Sonne.

Bei LOW messen wir 2,6 V ?!?!, bei HIGH 5V (so wie es sein soll).

Das erwarte ich mir bei einem Digitalen Multimeter ( Hohe Eingangswiderstad) und einem Pin das nicht als Ausgang definiert ist sondern per default Eingang ist. Mit digitalWrite(pin,HIGH/LOW) schaltest Du dann nicht das Pin auf HIGH bzw LOW sondern nur den Pullup an und aus.
Bei eingeschaltenen Pullup mißt Du 5V, ohne pullup irgendwas zufälliges zwischen 0 und 5V.

Grüße Uwe

Hi

Wuehlmaus:
-> HotSystems : Ich werte das mal als gutes Zeichen – seit 3 Jahren am basteln und diese Funktion noch nie gebrauch!

Der war gut - anerkennendes Kopfnicken :slight_smile:

…. obwohl mich das bei meinem Arduino-Privat-Schulungs-Workshop gestern auch zur Verzweiflung getrieben hat: Bei LOW messen wir 2,6 V ?!?!, bei HIGH 5V (so wie es sein soll).
Board: Arduino UNO,
Beschaltung: keine (also Board „nackig“),
Spannungs-Versorgung: über USB.

Das nenne ich doch Mal Urlaub - vor Allen für Deine Nachbarn :slight_smile:
Konntest Du schon feststellen, ob die Infektionen voranschreiten ?? :wink:
(Arduino-Virus ... endlich Mal ein Käfer, wo so ein Virus nützlich ist)

Auch schön, daß Du Dein Problem beheben konntest - so hatten Alle was davon!

MfG