Did I kill my Arduino?

Hi, I just had my Arduino for a few days, and I had just made a small test program that read an analog input value from a potentiometer and set pin13 pwm'ed based on that input.
It was working great, but now I accidentally connected the potentiometer the wrong way and I probably caused a short by doing so.
The power led went out, and I immediately removed the wires and the power led went back on.

When I now connect my Arduino, the power led works and it is still showing up as a COM-port in windows.
Both the RX and TX led flash simultaneously a couple of times when I connect it.
It looks like the program I uploaded is also still working, since the L led is on a little, and changes brightness when I touch the analog input connector.

When I try to upload a program however, only the RX led flashes a couple of times, but then nothing happens.
The error I get is:

Using Port : \.\COM5
Using Programmer : stk500v1
Overriding Baud Rate : 19200
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51] [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

I did find some similar topics, but no real solutions.
Is there any chance I can fix this, or does anyone know which component could be broken?

Did upload sketches worked always? Or you did it only once until now?

Which Arduino model do you have?
What was the power source? USB? External?
Which pin was the input for potenciomenter?

I have the Arduino Deciemella, and I'm using it USB powered.
The input pin was analog pin 2.

I had done a couple of uploads before which all worked fine.

It’s likely depending on how you miswired it. Just the pin or the even the whole port could be dead.

Even if that port is dead, shouldn't uploading still work?

Edit: I just tried with an external power supply, but in that case the usb doesn't do anything (it doesn't even show up as a COM-port)
When I select USB power again, a COM-port shows up when I connect the usb.

Do you have a multimeter to check the +5v when powering off of external power?

When I power it from an external power supply the power led is on also, and between 5V and GND I do indeed measure exactly 5V.

From what the pin13 led does, it appears as if the program is still able to run, and is reading random data from the analogRead. (sometimes the led is brighter then other times)
I did try again to connect the potentiometer, and it doesn't respond to that though, so it's quite likely that that pin is indeed broken.

I still hope that the rest of the board isn't broken though.

Kind of tedious, but you could try toggling each pin to verify. Maybe hang a 1k ohm resistor to from the pin to ground, simulating a small load while toggling.

I'm not sure that I understand what you mean?
I should just connect each pin with a 1k resistor to ground one by one?
Then what is supposed to happen when it toggles? The program that is on there only reads analog pin 2 and sets pin 13, so I don't think anything will happen if I toggle any other pins?

Right, you can't program it. That does pose a problem and makes it very hard to debug.

What's voltage is on pins 0 and 1?

Pin 0 is 4.83V, pin 1 is 2.60V.
TX and RX leds aren't on though.

Looks like the TX pin on the Atmel is a little fishy. In the bootloader and when serial is initialized, pin 1 should be close to +5v.

Lets see if you can force that pin high by putting 10k ohm resistor from pin 1 to +5V

While that resistor's on there take a voltage reading again at pin 1. What voltage do you get?

Voltage is 4.83V with resistor.
Without resistor I now measure 3.8V

It sounds like the Atmel is not able to drive the TX pin and that's why it's not responding to the PC.

Ok, well thanks for your help!
So it's quite likely that just replacing the microcontroller is enough to make it work again (that's still cheaper than a complete new board)?

Ok, well thanks for your help!

No problem!

Remember, you will need to program the bootloader or find a store that sells them preprogrammed.

Good luck.

I found some on Ebay pre-programmed with the bootloader for $5.

Ok, the new chip didn't work, but it looks like the chip may not even have been broken...
I used a bit of foam that they use to place chips on to put between my expirement board and the arduino.
I didn't think that this foam is conductive, but it is and this was causing the Arduino to misbehave.

I haven't tested with the old chip yet, but anyway everything is working again so I'm happy :slight_smile:

That foam isn't VERY conductive, it doesn't need to be to dissipate a static charge. But it is conductive enough to make a chip misbehave. :wink: